summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-28 04:30:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-28 04:37:17 +0200
commitcfdaf72f94a1f6c659d8894ef3f096cfa2b181e9 (patch)
tree0672bffcf3c58eaefc3869c264dda7c3bc46bd59
parentdev-python/hvac: Bump to 2.2.0 (diff)
downloadgentoo-cfdaf72f94a1f6c659d8894ef3f096cfa2b181e9.tar.gz
gentoo-cfdaf72f94a1f6c659d8894ef3f096cfa2b181e9.tar.bz2
gentoo-cfdaf72f94a1f6c659d8894ef3f096cfa2b181e9.zip
dev-python/noseofyeti: Bump to 2.4.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/noseofyeti/Manifest1
-rw-r--r--dev-python/noseofyeti/noseofyeti-2.4.9.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/noseofyeti/Manifest b/dev-python/noseofyeti/Manifest
index f681ba7520d8..74bdef1796bd 100644
--- a/dev-python/noseofyeti/Manifest
+++ b/dev-python/noseofyeti/Manifest
@@ -1 +1,2 @@
DIST noseofyeti-2.4.8.tar.gz 35866 BLAKE2B 6f11c7eb1db03ed27a8838e8b774cea97189609d8b7204facc3784968119878944b28231ab1f0d42f3eaa2679fee15df465e9069d1b4473ce8e5cd1749ace0b5 SHA512 78c685da52e993dc28c758dbf4395bbd544d0f4e9993f17a7f1ce267d03ba1c4a5e43cfcb2b2110e6fc21dcc60c6fcdd2bafb3f2d8ab2535a9429430ffc9308a
+DIST noseofyeti-2.4.9.tar.gz 35853 BLAKE2B d0c22bd6ea0cc41b1034dcfe397d2de72284630523a9210bb7c7290a0dd86414876e2c9c6ac3e63cd640eeb72bfed4617feea467f1a983bfd35f2f4239e28452 SHA512 2f6ff27fe08c91957d6c2f6dfea7fb4eba268245fc4444991799a2a102d616e536dcf49099c31962e8c8106564e8545edc1d2238a1a76278e0929d6387117bac
diff --git a/dev-python/noseofyeti/noseofyeti-2.4.9.ebuild b/dev-python/noseofyeti/noseofyeti-2.4.9.ebuild
new file mode 100644
index 000000000000..97c4ffc90e9f
--- /dev/null
+++ b/dev-python/noseofyeti/noseofyeti-2.4.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A custom python codec that provides an RSpec style dsl for python"
+HOMEPAGE="
+ https://github.com/delfick/nose-of-yeti/
+ https://pypi.org/project/noseOfYeti/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires alt-pytest-asyncio
+ tests/test_using_pytest.py::TestPyTest::test_it_collects_tests_correctly
+)