summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:26:45 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:03 -0400
commitd016d93c66f07b621c71eb32342c2042ea9bf84d (patch)
treeb95675eae56bec8f9aab64d74351576a57b4fd27
parentx11-misc/dclock: pass -std=gnu89 (diff)
downloadgentoo-d016d93c66f07b621c71eb32342c2042ea9bf84d.tar.gz
gentoo-d016d93c66f07b621c71eb32342c2042ea9bf84d.tar.bz2
gentoo-d016d93c66f07b621c71eb32342c2042ea9bf84d.zip
x11-misc/x2vnc: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild b/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild
index 03384930c47f..610ab7161a8d 100644
--- a/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild
+++ b/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="Control a remote computer running VNC from X"
HOMEPAGE="https://fredrik.hubbe.net/x2vnc.html"
SRC_URI="https://fredrik.hubbe.net/x2vnc/${P}.tar.gz"
@@ -31,6 +33,12 @@ PATCHES=(
"${FILESDIR}"/${P}-clang16.patch
)
+src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
+ default
+}
+
src_install() {
dodir /usr/share /usr/bin
emake DESTDIR="${D}" install