summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-07-06 10:11:54 -0400
committerMatt Turner <mattst88@gentoo.org>2023-07-06 10:11:54 -0400
commitd02eb2b056fd7dd282713d0fe145d456ce869b26 (patch)
tree2c75e4bce29e3c7a7c4503389589c196dc7cfdf0
parentmedia-libs/gexiv2: Add patch to fix compatibility with exiv2-0.28 (diff)
downloadgentoo-d02eb2b056fd7dd282713d0fe145d456ce869b26.tar.gz
gentoo-d02eb2b056fd7dd282713d0fe145d456ce869b26.tar.bz2
gentoo-d02eb2b056fd7dd282713d0fe145d456ce869b26.zip
dev-libs/wayland-protocols: Version bump to 1.32
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.32.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 7015e6b1aabe..84c7db5a265f 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1 +1,2 @@
DIST wayland-protocols-1.31.tar.xz 85524 BLAKE2B c3c21eb44f31fda1901b7aa87b15420f246893184f114d1776ef54224d4d05255b7691349ba546ba782df8fcbd64e39446caa11e2f96125cad9acb1cefad5f3d SHA512 402ce1915300e29afe554d77965ee0a28a5f22fdb5b901c4c640e59b9f3a9c11094e1edae87eea1e76eea557f6faf0c34a0c28ee7f6babb4dc3719329c4e25bf
+DIST wayland-protocols-1.32.tar.xz 90452 BLAKE2B 80e38270526c9da13c39263a60e7d2c330a1a4b1dfecec03fadda747f1a2e3dff95b30373aa19e133ae999fa15bdcdd64aa9ebbb54acf571f980a3f6088ea9be SHA512 90bbd52daf342b98823ddeed04e349ae242d2eaf925ab8d603cceb36c980c83b5681bb890961e0d49584cb5c2e60a33abf8821770c6ab87956383630bd5b7966
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.32.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.32.ebuild
new file mode 100644
index 000000000000..761831b38427
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.32.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}