summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2021-10-19 16:36:20 +0200
committerHanno Böck <hanno@gentoo.org>2021-10-19 16:36:20 +0200
commitd0323090c3c3607e8f6c419f211d05c68f0a1190 (patch)
treeafca82617c6808c17091bdccc3ac60e7bb159c68
parentwww-client/chromium: beta channel bump to 95.0.4638.54 (diff)
downloadgentoo-d0323090.tar.gz
gentoo-d0323090.tar.bz2
gentoo-d0323090.zip
net-im/gajim: Version bump
Fixes CVE-2021-41055 (DoS via crafted message). Fix DISTUTILS_USE_SETUPTOOLS warning. Remove historymanager patch, merged upstream. Bug: https://bugs.gentoo.org/show_bug.cgi?id=817791 Closes: https://bugs.gentoo.org/show_bug.cgi?id=809050 Closes: https://bugs.gentoo.org/show_bug.cgi?id=818799 Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.28, Repoman-3.0.3
-rw-r--r--net-im/gajim/Manifest1
-rw-r--r--net-im/gajim/gajim-1.3.3.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/net-im/gajim/Manifest b/net-im/gajim/Manifest
index 8aa6dc2e9628..81fc64dc5ef7 100644
--- a/net-im/gajim/Manifest
+++ b/net-im/gajim/Manifest
@@ -1,2 +1,3 @@
DIST gajim-1.3.1-2.tar.gz 9538193 BLAKE2B 2517b3eeaf3d8b9304e72c82e533d7424b7deb48d2543f366b91b8cf9a3e278f5b4d271d9128529f8e623f6b6fa26b5b97932112598118bf4ec24f97c4199669 SHA512 01d0e77e856935c7d388144fdc8c33271f41752a3544f713eb0ffe070bb7aee6fb3ae28aeddcda69298e405de21bc2ef004e8d7f4c59b3b09eb9366bbd6b0642
DIST gajim-1.3.2.tar.gz 9538320 BLAKE2B 9af561d4316a34480d073dcbf95fbc04ffd30bb4195633141ad1e9fa96145e61b54acff32891aadbdb93d0a775d69f2491e56f97fc67d2a1b2a76fcaab09f7ef SHA512 92c86d1fa2fab51b402b6ddc0b838f321ab744c9c2add743b3f1820215eef84cafabc50227606088d077bdd9f52998f4ca6f98ad153346b9fb37691b71e9c267
+DIST gajim-1.3.3.tar.gz 9886175 BLAKE2B 27c4163a5762e8fa72524f91d846439b5bd54aff8ec0c4f8ffe4061295540d986b71fc333a2d65110e87821efc5a96ce0dc8a519236c5d71df9a722c65851296 SHA512 b1b6ed1eeb9ce01c26240a0a0c1ff3991ac305787e2ed49ecf7ed9cc75789da2d0ec1c3a1fda6dc67fe440fa7aa143af9be1a837acfc94255d7027f63f55ced2
diff --git a/net-im/gajim/gajim-1.3.3.ebuild b/net-im/gajim/gajim-1.3.3.ebuild
new file mode 100644
index 000000000000..66d76d4a1c83
--- /dev/null
+++ b/net-im/gajim/gajim-1.3.3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="sqlite,xml"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="https://gajim.org/"
+SRC_URI="https://gajim.org/downloads/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+crypt geolocation jingle omemo remote rst +spell upnp +webp"
+S="${WORKDIR}/${PN}-${P}"
+
+COMMON_DEPEND="
+ dev-libs/gobject-introspection[cairo(+)]
+ >=x11-libs/gtk+-3.22:3[introspection]"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+ >=dev-util/intltool-0.40.1
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17-r1"
+RDEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/python-nbxmpp-2.0.2[${PYTHON_USEDEP}]
+ x11-libs/libXScrnSaver
+ app-crypt/libsecret[crypt,introspection]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ >=dev-python/secretstorage-3.1.1[${PYTHON_USEDEP}]
+ dev-python/css-parser[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ net-libs/libsoup[introspection]
+ media-libs/gsound[introspection]
+ crypt? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/python-gnupg-0.4.0[${PYTHON_USEDEP}] )
+ geolocation? ( app-misc/geoclue[introspection] )
+ jingle? (
+ net-libs/farstream:0.2[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-gtk
+ )
+ omemo? (
+ dev-python/python-axolotl[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ remote? (
+ >=dev-python/dbus-python-1.2.0[${PYTHON_USEDEP}]
+ sys-apps/dbus[X]
+ )
+ rst? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ spell? (
+ app-text/gspell[introspection]
+ app-text/hunspell
+ )
+ upnp? ( net-libs/gupnp-igd[introspection] )
+ webp? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ')"
+
+src_install() {
+ distutils-r1_src_install
+
+ # avoid precompressed man pages
+ rm -r "${D}/usr/share/man"
+ doman data/*.1
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}