summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-03 21:26:58 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-03 21:26:58 +0200
commitd050862ac8f993214d0fb3e5b61f30de887e5eb0 (patch)
tree8c0102b125519cb81c60c650e783e5abd8ceb2c8
parentdev-python/ensurepip-setuptools: drop 65.2.0 (diff)
downloadgentoo-d050862a.tar.gz
gentoo-d050862a.tar.bz2
gentoo-d050862a.zip
dev-python/fakeredis: drop 1.9.1, 1.9.2, 1.9.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/fakeredis/Manifest3
-rw-r--r--dev-python/fakeredis/fakeredis-1.9.1.ebuild88
-rw-r--r--dev-python/fakeredis/fakeredis-1.9.2.ebuild88
-rw-r--r--dev-python/fakeredis/fakeredis-1.9.3.ebuild87
4 files changed, 0 insertions, 266 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index 86e4f5049200..001a1a961b8d 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,5 +1,2 @@
DIST fakeredis-py-1.10.0.gh.tar.gz 88305 BLAKE2B 71ffec7f872c8021914e24ee83f250e1e27bf2117fabb3513b54ad635692f43cefaf565090d3829ee189844a83ccc517016d8a4f9c31da82b2188d8d951c4dcf SHA512 8fb32917c70931de50ef90526854ee7c0d888c04582a284864c19956868961cd689db0a7b3ad39e783f53741efde5a33cc600faf09fdeac7046fe29e9cd75933
-DIST fakeredis-py-1.9.1.gh.tar.gz 86742 BLAKE2B aa3f0b05f486219cb6eb560f561ab3e39cc32286cdc3f4f9aba667e256528b9338dcc03f3ddb00c0db30ddb181afe535e209f6ee0e98c56a0cad445e2181ec67 SHA512 27b4c95e596fdd69cecc737897edfedd6f55e7c5610394b1532e4b2aededaed6ad15763582ce6cc20821ac7ea096f60204f7080d247359d8e8d0d360a61c8e39
-DIST fakeredis-py-1.9.2.gh.tar.gz 87038 BLAKE2B 89ae3059d58fc9649979b787339a98eaedccd2b29814090e1bf0cb2c54836ed722d829b9965d3d0a92ff4d8ee714f6a455b85f68b383a5ba6a67aefd20f70410 SHA512 6a4d90c0c327787b7505542a3615f383735bffb021cbfc0a2adf2cfb87326c517d67c1df2f318cd84b60b8d0f1dcb20faea05529a856bf81b0f3ae6cc16823ed
-DIST fakeredis-py-1.9.3.gh.tar.gz 87068 BLAKE2B ee657bd0b04f5701c9e6445ca646fcc510dc3235407372fec9891f7d1adc5cacbd7a52e2d520c930f53491c2a18f5578d1b5186337953439f93fbb69a5e65ef8 SHA512 5255a75bae15ac325a41a273c70a467c8622d5992d40967e4ac21920c0563dbad808e9b82af203e72e3404f74a7bbfd2c12f5d854f9d353defec5b0333843266
DIST fakeredis-py-1.9.4.gh.tar.gz 87232 BLAKE2B b02b14960071ed38f6144b60d845d31d0d102f4d061dd2f156610f90385f35ff3128ab293fbf24049fd1f18a7558e9e13cc2f7179230a9837313acb2a7121053 SHA512 2fe74c5cc798edeef391136f8b09a651381faa04b7dd1e5a07007e6f89596e45970977b435e6fbdad03b73e9826a439da2e105ca9592fb3733547789d106182e
diff --git a/dev-python/fakeredis/fakeredis-1.9.1.ebuild b/dev-python/fakeredis/fakeredis-1.9.1.ebuild
deleted file mode 100644
index 1adc1b69c373..000000000000
--- a/dev-python/fakeredis/fakeredis-1.9.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=fakeredis-py-${PV}
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/cunla/fakeredis-py/
- https://pypi.org/project/fakeredis/
-"
-SRC_URI="
- https://github.com/cunla/fakeredis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- >=dev-python/redis-py-4.2[${PYTHON_USEDEP}]
- <dev-python/redis-py-4.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin redis
- sed -i -e '/redis/s:<[0-9.]*:*:' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # also lupa
- test/test_aioredis2.py::test_failed_script_error
- # TODO
- "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
- "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
- )
- local EPYTEST_IGNORE=(
- # these tests fail a lot...
- test/test_hypothesis.py
- )
- local args=(
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
- epytest "${args[@]}"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
diff --git a/dev-python/fakeredis/fakeredis-1.9.2.ebuild b/dev-python/fakeredis/fakeredis-1.9.2.ebuild
deleted file mode 100644
index 0b30f3d6134d..000000000000
--- a/dev-python/fakeredis/fakeredis-1.9.2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=fakeredis-py-${PV}
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/cunla/fakeredis-py/
- https://pypi.org/project/fakeredis/
-"
-SRC_URI="
- https://github.com/cunla/fakeredis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/redis-py-4.2[${PYTHON_USEDEP}]
- <dev-python/redis-py-4.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin redis
- sed -i -e '/redis/s:<[0-9.]*:*:' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # also lupa
- test/test_aioredis2.py::test_failed_script_error
- # TODO
- "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
- "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
- )
- local EPYTEST_IGNORE=(
- # these tests fail a lot...
- test/test_hypothesis.py
- )
- local args=(
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
- epytest "${args[@]}"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
diff --git a/dev-python/fakeredis/fakeredis-1.9.3.ebuild b/dev-python/fakeredis/fakeredis-1.9.3.ebuild
deleted file mode 100644
index 315d3ed64771..000000000000
--- a/dev-python/fakeredis/fakeredis-1.9.3.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=fakeredis-py-${PV}
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/cunla/fakeredis-py/
- https://pypi.org/project/fakeredis/
-"
-SRC_URI="
- https://github.com/cunla/fakeredis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/redis-py-4.2[${PYTHON_USEDEP}]
- <dev-python/redis-py-4.4[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin redis
- sed -i -e '/redis/s:<[0-9.]*:*:' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # also lupa
- test/test_aioredis2.py::test_failed_script_error
- # TODO
- "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
- "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
- )
- local EPYTEST_IGNORE=(
- # these tests fail a lot...
- test/test_hypothesis.py
- )
- local args=(
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
- epytest "${args[@]}"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}