summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-16 00:11:02 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-16 00:11:42 +0200
commitd05b5eeac17bba67f5f739397338b4cfed7f3239 (patch)
tree1b4437db39e5d1be370f7374afc95db1849926a6
parentnet-dns/getdns: drop old version (diff)
downloadgentoo-d05b5eeac17bba67f5f739397338b4cfed7f3239.tar.gz
gentoo-d05b5eeac17bba67f5f739397338b4cfed7f3239.tar.bz2
gentoo-d05b5eeac17bba67f5f739397338b4cfed7f3239.zip
net-analyzer/monitoring-plugins: drop old version
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-analyzer/monitoring-plugins/Manifest2
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.2-r4.ebuild103
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.3.ebuild106
3 files changed, 0 insertions, 211 deletions
diff --git a/net-analyzer/monitoring-plugins/Manifest b/net-analyzer/monitoring-plugins/Manifest
index eadf33d62d44..5d730fce5753 100644
--- a/net-analyzer/monitoring-plugins/Manifest
+++ b/net-analyzer/monitoring-plugins/Manifest
@@ -1,3 +1 @@
-DIST monitoring-plugins-2.2.tar.gz 2461548 BLAKE2B 0f68b492e089c6dfd09db6aab78ab4490f2e8983677c70dda4c3800a06380c066865587536a44f135d0e314006ed81a757cbfbd918f53e009f9d2c50b8e58db0 SHA512 5f8cfa132891d6d96e69bee3f2c26f7d4546f572be6a18f25ea5d9069f162cb2e424361289a5c26bec60d7b63d28a269437fd6f25645903a1c142fdcbbf77f27
DIST monitoring-plugins-2.3.1.tar.gz 2529669 BLAKE2B 8dbbab78c1e57e249024fe57439acb41960585f2cccba20d03ca75a04b87e84752665f49cfe545c6a409d29094077dac0485aef872586f853e2f0f2187bf5070 SHA512 0ae76bc776997ed23d142ad9a688edc4df9b8ec0f9539b446e4fb4849a165cc88e97cbfb3a7a9a450de452e021d38f2e4ada7e8a22d78cf58e17e266472d01d7
-DIST monitoring-plugins-2.3.tar.gz 2528556 BLAKE2B d8c8886aea900a172e5693de766edb6b7ef7aac5ee94fec1f5c14cb0e9873623b14a965cc8852abb4ed44934d5111a86e130e7c37201a03de42bc996797302de SHA512 926065667dff6c608ae5b7da39f6416bfc2443b9e1cdef68cd5d19be99da1b6fc6f23ef87b05731312b5d7ad76d01f0242fc9e544dbb4dd00dbafa0e27434d2e
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.2-r4.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.2-r4.ebuild
deleted file mode 100644
index 62c9fc037488..000000000000
--- a/net-analyzer/monitoring-plugins/monitoring-plugins-2.2-r4.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic user
-
-DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
-HOMEPAGE="https://www.monitoring-plugins.org/"
-SRC_URI="https://www.monitoring-plugins.org/download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 sparc x86"
-IUSE="gnutls ipv6 ldap mysql dns fping game postgres radius samba snmp ssh +ssl"
-
-# Most of the plugins use automagic dependencies, i.e. the plugin will
-# get built if the binary it uses is installed. For example, check_snmp
-# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
-# installed. End result: most of our runtime dependencies are required
-# at build time as well.
-#
-# REAL_DEPEND contains the dependencies that are actually needed to
-# build. DEPEND contains those plus the automagic dependencies.
-#
-REAL_DEPEND="dev-lang/perl
- ldap? ( net-nds/openldap )
- mysql? ( dev-db/mysql-connector-c:= )
- postgres? ( dev-db/postgresql:= )
- ssl? (
- !gnutls? (
- dev-libs/openssl:0=
- )
- gnutls? ( net-libs/gnutls )
- )
- radius? ( net-dialup/freeradius-client )"
-
-DEPEND="${REAL_DEPEND}
- dns? ( net-dns/bind-tools )
- game? ( games-util/qstat )
- fping? ( net-analyzer/fping )
- samba? ( net-fs/samba )
- ssh? ( net-misc/openssh )
- snmp? ( dev-perl/Net-SNMP
- net-analyzer/net-snmp[-minimal] )"
-
-# Basically everything collides with nagios-plugins.
-RDEPEND="${DEPEND}
- !net-analyzer/nagios-plugins"
-
-# At least one test is interactive.
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}/define-own-mysql-port-constant.patch" )
-
-src_configure() {
- append-flags -fno-strict-aliasing
-
- # Use an array to prevent econf from mangling the ping args.
- local myconf=()
-
- if use ssl; then
- myconf+=( $(use_with !gnutls openssl /usr)
- $(use_with gnutls gnutls /usr) )
- else
- myconf+=( --without-openssl )
- myconf+=( --without-gnutls )
- fi
-
- # The autodetection for these two commands can hang if localhost is
- # down or ICMP traffic is filtered. Bug #468296.
- myconf+=( --with-ping-command="/bin/ping -4 -n -U -w %d -c %d %s" )
-
- if use ipv6; then
- myconf+=( --with-ping6-command="/bin/ping -6 -n -U -w %d -c %d %s" )
- fi
-
- econf \
- $(use_with mysql) \
- $(use_with ipv6) \
- $(use_with ldap) \
- $(use_with postgres pgsql /usr) \
- $(use_with radius) \
- "${myconf[@]}" \
- --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
- --sysconfdir="/etc/nagios"
-}
-
-DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
- NEWS README REQUIREMENTS SUPPORT THANKS )
-
-pkg_preinst() {
- enewgroup nagios
- enewuser nagios -1 /bin/bash /var/nagios/home nagios
-}
-
-pkg_postinst() {
- elog "This ebuild has a number of USE flags that determine what you"
- elog "are able to monitor. Depending on what you want to monitor, some"
- elog "or all of these USE flags need to be set."
- elog
- elog "The plugins are installed in ${EROOT%/}/usr/$(get_libdir)/nagios/plugins"
-}
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.ebuild
deleted file mode 100644
index 8beced678194..000000000000
--- a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-
-DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
-HOMEPAGE="https://www.monitoring-plugins.org/"
-SRC_URI="https://www.monitoring-plugins.org/download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
-IUSE="curl gnutls ipv6 ldap mysql dns fping game postgres radius samba snmp ssh +ssl"
-
-# Most of the plugins use automagic dependencies, i.e. the plugin will
-# get built if the binary it uses is installed. For example, check_snmp
-# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
-# installed. End result: most of our runtime dependencies are required
-# at build time as well.
-#
-# REAL_DEPEND contains the dependencies that are actually needed to
-# build. DEPEND contains those plus the automagic dependencies.
-#
-REAL_DEPEND="dev-lang/perl
- curl? (
- dev-libs/uriparser
- net-misc/curl
- )
- ldap? ( net-nds/openldap )
- mysql? ( || ( dev-db/mysql-connector-c dev-db/mariadb-connector-c ) )
- postgres? ( dev-db/postgresql:= )
- ssl? (
- !gnutls? (
- dev-libs/openssl:0=
- )
- gnutls? ( net-libs/gnutls )
- )
- radius? ( net-dialup/freeradius-client )"
-
-DEPEND="${REAL_DEPEND}
- dns? ( net-dns/bind-tools )
- game? ( games-util/qstat )
- fping? ( net-analyzer/fping )
- samba? ( net-fs/samba )
- ssh? ( net-misc/openssh )
- snmp? ( dev-perl/Net-SNMP
- net-analyzer/net-snmp[-minimal] )"
-
-# Basically everything collides with nagios-plugins.
-RDEPEND="${DEPEND}
- acct-group/nagios
- acct-user/nagios
- !net-analyzer/nagios-plugins"
-
-# At least one test is interactive.
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}/define-own-mysql-port-constant.patch" )
-
-src_configure() {
- append-flags -fno-strict-aliasing
-
- # Use an array to prevent econf from mangling the ping args.
- local myconf=()
-
- if use ssl; then
- myconf+=( $(use_with !gnutls openssl /usr)
- $(use_with gnutls gnutls /usr) )
- else
- myconf+=( --without-openssl )
- myconf+=( --without-gnutls )
- fi
-
- # The autodetection for these two commands can hang if localhost is
- # down or ICMP traffic is filtered. Bug #468296.
- myconf+=( --with-ping-command="/bin/ping -4 -n -U -w %d -c %d %s" )
-
- if use ipv6; then
- myconf+=( --with-ping6-command="/bin/ping -6 -n -U -w %d -c %d %s" )
- fi
-
- econf \
- $(use_with curl libcurl) \
- $(use_with curl uriparser) \
- $(use_with mysql) \
- $(use_with ipv6) \
- $(use_with ldap) \
- $(use_with postgres pgsql /usr) \
- $(use_with radius) \
- "${myconf[@]}" \
- --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
- --sysconfdir="/etc/nagios"
-}
-
-DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
- NEWS README REQUIREMENTS SUPPORT THANKS )
-
-pkg_postinst() {
- elog "This ebuild has a number of USE flags that determine what you"
- elog "are able to monitor. Depending on what you want to monitor, some"
- elog "or all of these USE flags need to be set."
- elog
- elog "The plugins are installed in ${EROOT}/usr/$(get_libdir)/nagios/plugins"
-}