summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-11-22 04:42:25 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-24 15:26:08 +0200
commitd086d664a10d291ee5a822fb98e79f21093567e5 (patch)
tree1c5a98a8f18f644be5f5bd2ae850657e817e70cc
parentmedia-gfx/alembic: drop old (diff)
downloadgentoo-d086d664a10d291ee5a822fb98e79f21093567e5.tar.gz
gentoo-d086d664a10d291ee5a822fb98e79f21093567e5.tar.bz2
gentoo-d086d664a10d291ee5a822fb98e79f21093567e5.zip
www-apps/gitea: Version bump 1.12.6.
Bug: https://bugs.gentoo.org/754948 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.12.6.ebuild135
2 files changed, 136 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index ddafc399ab2f..0c6bde6e7793 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1 +1,2 @@
DIST gitea-1.12.4.tar.gz 135170598 BLAKE2B 5db5bda4b2a9ea94b97e2ea59416cb6a2f95d53cdd9804d4d38686413134b00935b859ab5d14883f0e9238472108b96d66e6c6f77cafb5eb9c505fd945abc97b SHA512 6d28cd1fca4332c12b2b9485775289cd86b450bb9072c6c200b1d7cc4e5ac439f5d5a39cb788228f8712a0e73990ff9f4b326ca1d8fa90bc0691c50925e1a8f1
+DIST gitea-1.12.6.tar.gz 135134376 BLAKE2B 762f5403a9c5524182c717d6d028ad7fae2ce01d66960635d5e3d1e0ad9027c431efb3604a89061d5354ac126eea8e412b52d9c9d1243b1dc56b9ecbabd2e7db SHA512 c581f84ffe793b80e445c70f3e60ed54a663ef2b2579959b4f1bd4ce5aa0f470ef6d6b13476cc920e615e18ef79ff461896c75ce8282f9b774e939dbbe1f2a49
diff --git a/www-apps/gitea/gitea-1.12.6.ebuild b/www-apps/gitea/gitea-1.12.6.ebuild
new file mode 100644
index 000000000000..f4f0af94aa84
--- /dev/null
+++ b/www-apps/gitea/gitea-1.12.6.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit fcaps go-module tmpfiles systemd
+MY_PV="${PV/_rc/-rc}"
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.io"
+
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${MY_PV}/gitea-src-${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64"
+ S="${WORKDIR}"
+else
+ EGIT_REPO_URI="https://github.com/go-gitea/gitea"
+ inherit git-r3
+ S="${WORKDIR}/${P}"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="+acct build-client pam sqlite"
+
+BDEPEND="build-client? ( >=net-libs/nodejs-10[npm] )"
+COMMON_DEPEND="
+ acct? (
+ acct-group/git
+ acct-user/git[gitea] )
+ pam? ( sys-libs/pam )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ dev-vcs/git"
+
+DOCS=(
+ custom/conf/app.ini.sample CONTRIBUTING.md README.md
+)
+FILECAPS=(
+ cap_net_bind_service+ep usr/bin/gitea
+)
+PATCHES=(
+ "${FILESDIR}/1.12-fix-vendoring.patch"
+)
+
+RESTRICT="test"
+QA_PRESTRIPPED="usr/bin/gitea"
+
+src_prepare() {
+ default
+
+ local sedcmds=(
+ -e "s#^RUN_MODE = dev#RUN_MODE = prod#"
+ -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
+ -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
+ -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
+ -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
+ -e "s#^MODE = console#MODE = file#"
+ -e "s#^LEVEL = Trace#LEVEL = Info#"
+ -e "s#^LOG_SQL = true#LOG_SQL = false#"
+ -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
+ -e "s#^APP_ID =#;APP_ID =#"
+ -e "s#^TRUSTED_FACETS =#;TRUSTED_FACETS =#"
+ )
+
+ sed -i "${sedcmds[@]}" custom/conf/app.ini.sample || die
+ if use sqlite ; then
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.ini.sample || die
+ fi
+
+ einfo "Remove tests which are known to fail with network-sandbox enabled."
+ rm ./modules/migrations/github_test.go || die
+
+ einfo "Remove tests which depend on gitea git-repo."
+ rm ./modules/git/blob_test.go || die
+ rm ./modules/git/repo_test.go || die
+
+ # Remove already build assets (like frontend part)
+ use build-client && emake clean-all
+}
+
+src_compile() {
+ local gitea_tags=(
+ bindata
+ $(usev pam)
+ $(usex sqlite 'sqlite sqlite_unlock_notify' '')
+ )
+ local gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+ local makeenv=(
+ TAGS="${gitea_tags[@]}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[@]}"
+ )
+ [[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${MY_PV}")
+
+ if use build-client; then
+ # -j1 as Makefile doesn't handle dependancy correctly, and is not
+ # useful as golang compiler don't use this info.
+ env "${makeenv[@]}" emake -j1 build
+ else
+ env "${makeenv[@]}" emake backend
+ fi
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r2 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.ini.sample app.ini
+ if use acct ; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ go-module_pkg_postinst
+ tmpfiles_process gitea.conf
+}