summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 02:54:48 +0100
committerSam James <sam@gentoo.org>2022-05-31 02:56:46 +0100
commitd086e3bda928fd1298ecf16b75a54c7480acef53 (patch)
tree7665a9be1ab7e93d8c47f2fffa3312132870640b
parentdev-python/python-ly: add 0.9.7 (diff)
downloadgentoo-d086e3bd.tar.gz
gentoo-d086e3bd.tar.bz2
gentoo-d086e3bd.zip
dev-python/pyacoustid: add 1.2.2
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pyacoustid/Manifest1
-rw-r--r--dev-python/pyacoustid/pyacoustid-1.2.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyacoustid/Manifest b/dev-python/pyacoustid/Manifest
index b68f519a9475..f17b3b2636b3 100644
--- a/dev-python/pyacoustid/Manifest
+++ b/dev-python/pyacoustid/Manifest
@@ -1 +1,2 @@
DIST pyacoustid-1.2.0.tar.gz 15770 BLAKE2B 9a5d62a8b8450393aec103d3755ed9e1fa999b6d4b25d1180d12e96020bb8bcf44b32f7de2e7de2ab0902ca9e65b352bc09edca173ce738019f4ca3330489875 SHA512 45827841df97b0f3a5d090edb076456fb822dfb35f3efbe55cc2877801b6c706f22a38f216d4ce7e4217d7da650e2116cfd987ea87000c828b06221fb8b06312
+DIST pyacoustid-1.2.2.tar.gz 15869 BLAKE2B 01f327dd640819dd799f48b32e859fe39dccda3fd62714bf324c8219cf7053b36f1399793523634e9d4f3c6405bed5050abb34bdf53c72ff0ee22708fb57225a SHA512 5bcb3f017c3013eb8fc9e335540a1f5e6a52fc2fefa53d5ef246ba16e4ff615dd1d1cf08b5c80b1a38b149e0fa7dc0b15e4890dcc3f5478ef874b4ec22cf0813
diff --git a/dev-python/pyacoustid/pyacoustid-1.2.2.ebuild b/dev-python/pyacoustid/pyacoustid-1.2.2.ebuild
new file mode 100644
index 000000000000..5428e169fb59
--- /dev/null
+++ b/dev-python/pyacoustid/pyacoustid-1.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Chromaprint and the AcoustID web service"
+HOMEPAGE="https://pypi.org/project/pyacoustid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/audioread[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ media-libs/chromaprint
+"
+
+src_install() {
+ distutils-r1_src_install
+
+ if use examples ; then
+ docinto examples
+ dodoc aidmatch.py fpcalc.py
+ docompress -x /usr/share/doc/${PF}/examples/
+ fi
+}