summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-12 04:28:19 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-12 04:28:19 +0200
commitd09ef457994fc80819e7921e1084b63e6333e01d (patch)
tree76ac2a934a35407ae72c8d2e1cde5bb9b9430a8b
parentdev-python/poetry-plugin-export: Bump to 1.8.0 (diff)
downloadgentoo-d09ef457994fc80819e7921e1084b63e6333e01d.tar.gz
gentoo-d09ef457994fc80819e7921e1084b63e6333e01d.tar.bz2
gentoo-d09ef457994fc80819e7921e1084b63e6333e01d.zip
dev-python/mcbootflash: Bump to 8.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mcbootflash/Manifest1
-rw-r--r--dev-python/mcbootflash/mcbootflash-8.0.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mcbootflash/Manifest b/dev-python/mcbootflash/Manifest
index 7bf319e6e80e..9a1eb412ceb0 100644
--- a/dev-python/mcbootflash/Manifest
+++ b/dev-python/mcbootflash/Manifest
@@ -1 +1,2 @@
DIST mcbootflash-8.0.1.tar.gz 24906 BLAKE2B 2af5c73de29aa089d33047179ce196507ab1ed1ae224b6f680341a818d8056915271b121cf1ac32f31dd5e33e095f2b82fcddf5907bdb5513a17e009ac242f7f SHA512 fc4093873bbfc0a29d2c09b2f62247dd659b4c9d531613a2a18d6b452f7a0e573b5fa087d82686045af1ba6f7811ca3ccba0f109ada71c42925e8c01faa0fe1d
+DIST mcbootflash-8.0.2.tar.gz 27121 BLAKE2B caded3a13266db46ac1b9f35c0a027e9dbfa2c430da96992bf689d4b32574406a7d0c736da82dbe7c473189a8941db8548f59828010e755f33c0342c8c593be2 SHA512 542dcf9af6c22f2deae786fa547e99e4df07b8e3eda7b007a9ead96386c2bf880d8485985b3de399ecd496bf982b6a0308c3f82b49c5914bca09c961822566c6
diff --git a/dev-python/mcbootflash/mcbootflash-8.0.2.ebuild b/dev-python/mcbootflash/mcbootflash-8.0.2.ebuild
new file mode 100644
index 000000000000..2821aae561f3
--- /dev/null
+++ b/dev-python/mcbootflash/mcbootflash-8.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Flash firmware to devices running Microchip's 16-bit bootloader"
+HOMEPAGE="
+ https://pypi.org/project/mcbootflash/
+ https://github.com/bessman/mcbootflash/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/bincopy-20.0.0[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-reserial[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --replay
+}