summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-02 15:09:31 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-02 15:54:13 +0100
commitd0a53d75390d0d69bd6c409d6089ad7c8f4e06bb (patch)
tree0cd039d8a0fd5b51e03c3585c670067332a7796b
parentdev-python/django: Bump to 4.1.5 (diff)
downloadgentoo-d0a53d75.tar.gz
gentoo-d0a53d75.tar.bz2
gentoo-d0a53d75.zip
dev-python/pyglet: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyglet/Manifest1
-rw-r--r--dev-python/pyglet/pyglet-2.0.3.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index 5f223c8b4f8b..1ac6c01a5339 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -2,3 +2,4 @@ DIST pyglet-1.5.27.gh.tar.gz 6532179 BLAKE2B f1dc668530a69e275860befe11f4c86003c
DIST pyglet-2.0.0.gh.tar.gz 6201132 BLAKE2B e72436804688e9022f0efc7da7fac5eb31ed2d35632612149b52431167db98f1d2e8bc3824ef6bd69851a8bf609d5098ea5f5c77aa7bcf5a527457c62ed47586 SHA512 2dde724f0b5f284d0094109a7077464ac4ec76ea905c91ddc096032ac849ee9720ee36926e9f11969169906c7e45580789001dfc657edc2e737ad116c48c588a
DIST pyglet-2.0.1.gh.tar.gz 6202313 BLAKE2B be77d8b1736a41ff97c91db2019716eb85be87c91847f1588ffa8c502224b127aa04b038a207890a7abd099f9a956cfa8836d25e50a913f3a8439edfc078942e SHA512 a8670a8845b1743347b1b8cac19ee62056b2ea819ba2e14e567bc2d42f4ff7d1dc2c10e782b1bd670aef69e78971dca8d740787065ef1c2923cb62a3570e7bec
DIST pyglet-2.0.2.1.gh.tar.gz 6206090 BLAKE2B e671e1800f8f9e80ff301692973e6085c63b751944d221added744edf3910dd13c15f741637b23f04777b64bfe2865698410be1859009bc1455cf51458e8916a SHA512 4b6d4883025b55d7e1515c65c0b18a5b24d152a5e7f547379329388046c2f1818f9e203d2913825a1156eb3271100b6257f334310959c2e7a1b4ba2b61f2d398
+DIST pyglet-2.0.3.gh.tar.gz 6213542 BLAKE2B 7a47df69761d718e6b1a700105ca7e75b650109d37bea340cae147885ea2158da9af45c9c5733cd6cdc41e17800471921457dda281285e4c6836191200a92be2 SHA512 7617c34dfc65d8a957e6e4093c467d2debcd36e053ef0e1b350cc63fa886e59a6e8cfa0bbbc9db163c736f5ec975c0a105f7ccb0c8bb193744b692d550e0f757
diff --git a/dev-python/pyglet/pyglet-2.0.3.ebuild b/dev-python/pyglet/pyglet-2.0.3.ebuild
new file mode 100644
index 000000000000..eb0c3fb08649
--- /dev/null
+++ b/dev-python/pyglet/pyglet-2.0.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="
+ https://pyglet.org/
+ https://github.com/pyglet/pyglet/
+ https://pypi.org/project/pyglet/
+"
+SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples image +sound"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/fontconfig
+ )
+"
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ image? ( || (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ ) )
+ sound? ( || (
+ media-libs/openal
+ media-sound/pulseaudio
+ ) )
+"
+# ffmpeg? ( media-libs/avbin-bin )
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ xdg_environment_reset
+
+ local EPYTEST_DESELECT=(
+ # lacking device/server permissions
+ tests/unit/media/test_listener.py::test_openal_listener
+ tests/unit/media/test_listener.py::test_pulse_listener
+ # fragile to load
+ tests/unit/test_clock_freq.py::test_elapsed_time_between_tick
+ )
+ if [[ ${EPYTHON} == python3.11 ]]; then
+ EPYTEST_DESELECT+=(
+ # broken test
+ # https://github.com/pyglet/pyglet/issues/606
+ tests/unit/test_events.py::test_push_handlers_instance
+ )
+ fi
+
+ # Specify path to avoid running interactive tests
+ # We could add in integration tests, but they're slow
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest tests/unit || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}