summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gmail.com>2017-09-20 09:54:56 -0500
committerPatrice Clement <monsieurp@gentoo.org>2017-10-04 11:51:24 +0200
commitd0a98d38c595fb08985ef9f4e61857a23fe6ca27 (patch)
treed40940eb8a9019e7d2e0ec95a4c60cf26bbc7046
parentsci-biology/gibbs: remove unused file. (diff)
downloadgentoo-d0a98d38c595fb08985ef9f4e61857a23fe6ca27.tar.gz
gentoo-d0a98d38c595fb08985ef9f4e61857a23fe6ca27.tar.bz2
gentoo-d0a98d38c595fb08985ef9f4e61857a23fe6ca27.zip
dev-libs/newt: version bump to 0.52.20 and bump to EAPI 6.
* Bump to upsream version 0.52.20. * Convert to EAPI=6, which requires a small patch adjustment for -p1. * Remove now-unused eutils inherit. * Add 3.x to PYTHON_COMPAT since upstream added py3 support. * Add :0 slot on ncurses dep. Closes: https://bugs.gentoo.org/598904 Closes: https://github.com/gentoo/gentoo/pull/5738
-rw-r--r--dev-libs/newt/Manifest1
-rw-r--r--dev-libs/newt/files/newt-0.52.13-gold.patch4
-rw-r--r--dev-libs/newt/newt-0.52.20.ebuild92
3 files changed, 95 insertions, 2 deletions
diff --git a/dev-libs/newt/Manifest b/dev-libs/newt/Manifest
index fc121d048fcf..1fc0b69bfd42 100644
--- a/dev-libs/newt/Manifest
+++ b/dev-libs/newt/Manifest
@@ -1,2 +1,3 @@
DIST newt-0.52.15.tar.gz 183171 SHA256 7a6151923e7a8a950f9a8a21668a5780d09b0f35f9d76a7ec606c71c35a0e241 SHA512 f93798e8e9e33b4bc1bbb6039d94ccdf55be76a0e0f918eb32a241fe527ea61121a8fc35ccd699e3f6202eb367ba4b4025b30264bd9b0face7c16782f113051e WHIRLPOOL 3b23d149964bb63b6c1de2f84c7d8eaac4ecb004698135e41afd0e3ca2702f8687f9ca46a4bc10c2d4a372b9b10e7dd792a6d56deee59e2f30f942776f6d625b
DIST newt-0.52.18.tar.gz 180425 SHA256 771b0e634ede56ae6a6acd910728bb5832ac13ddb0d1d27919d2498dab70c91e SHA512 223b4fba9568d7ddddd9292f52d5e556a24403642d1dac97b58c8ede698bc182ce7d5afd31df2cb1c5b8a8850529b50ce71d8ad84856be8d42fad0f1a33a48f8 WHIRLPOOL e4ca7b572579834df0f73f1bd65a19be48e186f253ac2e82713a0e5ed902ca1fcb8cec88da508519e6a0e88efcac77fbaa0000525bb7659264849322bc3c1c55
+DIST newt-0.52.20.tar.gz 181163 SHA256 8d66ba6beffc3f786d4ccfee9d2b43d93484680ef8db9397a4fb70b5adbb6dbc SHA512 0c10c373c6a5299a85fc38f32d3590fff3b26c4be40e6c85ed73c20724ef2fb094bf37a8c3b1b80a4bcdfc14fe59254d4419c391245c298a4e16788954b88236 WHIRLPOOL e695e6bb24a653377d73d461ae720d999af36873703a75127463e8d2a92d52a2d93011bbae32f6c3e8027cf31c906ed96dbfc88f2246e67dabd6b6359f7298c8
diff --git a/dev-libs/newt/files/newt-0.52.13-gold.patch b/dev-libs/newt/files/newt-0.52.13-gold.patch
index 5781dbf550f4..91626c6306e8 100644
--- a/dev-libs/newt/files/newt-0.52.13-gold.patch
+++ b/dev-libs/newt/files/newt-0.52.13-gold.patch
@@ -1,5 +1,5 @@
---- configure.ac~ 2011-11-09 23:50:21.000000000 +0900
-+++ configure.ac 2011-11-09 23:54:54.139482817 +0900
+--- a/configure.ac
++++ b/configure.ac
@@ -19,7 +19,8 @@
AC_MSG_CHECKING([for GNU ld])
LD=`$CC -print-prog-name=ld 2>&5`
diff --git a/dev-libs/newt/newt-0.52.20.ebuild b/dev-libs/newt/newt-0.52.20.ebuild
new file mode 100644
index 000000000000..c71f947af1b5
--- /dev/null
+++ b/dev-libs/newt/newt-0.52.20.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-r1 multilib autotools toolchain-funcs
+
+DESCRIPTION="Redhat's Newt windowing toolkit development files"
+HOMEPAGE="https://fedorahosted.org/newt/"
+SRC_URI="https://fedorahosted.org/releases/n/e/newt/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gpm nls tcl"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/popt-1.6
+ =sys-libs/slang-2*
+ elibc_uclibc? ( sys-libs/ncurses:0= )
+ gpm? ( sys-libs/gpm )
+ tcl? ( >=dev-lang/tcl-8.5:0 )
+ "
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # bug 73850
+ if use elibc_uclibc; then
+ sed -i -e 's:-lslang:-lslang -lncurses:g' Makefile.in || die
+ fi
+
+ sed -i Makefile.in \
+ -e 's|$(SHCFLAGS) -o|$(LDFLAGS) &|g' \
+ -e 's|-g -o|$(CFLAGS) $(LDFLAGS) -o|g' \
+ -e 's|-shared -o|$(CFLAGS) $(LDFLAGS) &|g' \
+ -e 's|instroot|DESTDIR|g' \
+ -e 's| make | $(MAKE) |g' \
+ -e "s| ar | $(tc-getAR) |g" \
+ || die "sed Makefile.in"
+
+ local langs=""
+ if [ -n "${LINGUAS}" ]; then
+ for lang in ${LINGUAS}; do
+ test -r po/${lang}.po && langs="${langs} ${lang}.po"
+ done
+ sed -i po/Makefile \
+ -e "/^CATALOGS = /cCATALOGS = ${langs}" \
+ || die "sed po/Makefile"
+ fi
+
+ eapply "${FILESDIR}"/${PN}-0.52.13-gold.patch \
+ "${FILESDIR}"/${PN}-0.52.14-tcl.patch \
+ "${FILESDIR}"/${PN}-0.52.15-makefile.patch
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ configuring() {
+ econf \
+ PYTHONVERS="${PYTHON}" \
+ $(use_with gpm gpm-support) \
+ $(use_with tcl) \
+ $(use_enable nls)
+ }
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ building() {
+ emake PYTHONVERS="${EPYTHON}"
+ }
+ python_foreach_impl building
+}
+
+src_install() {
+ installit() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHONVERS="${EPYTHON}" \
+ install
+ python_optimize
+ }
+ python_foreach_impl installit
+ dodoc peanuts.py popcorn.py tutorial.sgml
+ doman whiptail.1
+ einstalldocs
+}