summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 23:01:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 23:04:24 +0100
commitd0aed4f39fd3e1640821ae02eaa512cb46656957 (patch)
tree03f849ce2c74412ec781608ce9d93ce51c4e6ff5
parentdev-python/PyPDF2: Switch to PEP 517 build (diff)
downloadgentoo-d0aed4f3.tar.gz
gentoo-d0aed4f3.tar.bz2
gentoo-d0aed4f3.zip
dev-python/pypeg2: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pypeg2/pypeg2-2.15.2-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pypeg2/pypeg2-2.15.2-r2.ebuild b/dev-python/pypeg2/pypeg2-2.15.2-r2.ebuild
new file mode 100644
index 000000000000..c75dac24608f
--- /dev/null
+++ b/dev-python/pypeg2/pypeg2-2.15.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+MY_PN=pyPEG2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="An intrinsic PEG Parser-Interpreter for Python"
+HOMEPAGE="https://fdik.org/pyPEG/
+ https://pypi.org/project/pyPEG2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.15.1-test.patch )
+
+distutils_enable_tests unittest