summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-07 11:48:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-07 17:55:01 +0100
commitd0e91ae6dfdf68154f92637842048e1a8a3e24ed (patch)
tree8cd4e84d55c2a1734cc7663782b6e9e5e57d34b8
parentdev-python/ujson: Keyword 5.7.0 ppc, #893510 (diff)
downloadgentoo-d0e91ae6.tar.gz
gentoo-d0e91ae6.tar.bz2
gentoo-d0e91ae6.zip
dev-python/PyQtWebEngine: drop 5.15.5
Bug: https://bugs.gentoo.org/888203 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/PyQtWebEngine/Manifest1
-rw-r--r--dev-python/PyQtWebEngine/PyQtWebEngine-5.15.5.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/PyQtWebEngine/Manifest b/dev-python/PyQtWebEngine/Manifest
index 0dd22964e344..3cbff134bc2f 100644
--- a/dev-python/PyQtWebEngine/Manifest
+++ b/dev-python/PyQtWebEngine/Manifest
@@ -1,2 +1 @@
-DIST PyQtWebEngine-5.15.5.tar.gz 48610 BLAKE2B ea266c09965a6ee62e33d3970b145068271c9e1eb87839782e0100b5db2e90a0c002fc4d6f3d22ef9a5cb8c42a067bb45008b0392a0d8557bc6c5c9d77e6b75a SHA512 20eecd479ea757e3bf9855c7dafe0bbbc0cbc61be26509605a5c9a8026e54bb6e362069ecf4be74733dcf6eec154f6ed13933e334e4455b080e687abfd2659fa
DIST PyQtWebEngine-5.15.6.tar.gz 48871 BLAKE2B af7c30a0d2e65e12a6eb4a2d3a40d72f94f16a5b4e509f9366be4bfb7d4358b27b3f9c0a7e4a2e7254d38950cbbd6bd4eb88e321949d4d9a44e6ea7e06c2f902 SHA512 f744fb0468ccbc79aad23d941c8e96d537ceeedfae215c7095dbf36b04b3dd042f0ff80aeca25a23715964b7d6db3bc80513f509d15c6dd6bd51e42a1a4e1975
diff --git a/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.5.ebuild b/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.5.ebuild
deleted file mode 100644
index 8ac077883076..000000000000
--- a/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.5.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit python-r1 qmake-utils
-
-DESCRIPTION="Python bindings for QtWebEngine"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqtwebengine/ https://pypi.org/project/PyQtWebEngine/"
-
-MY_P=${PN}-${PV/_pre/.dev}
-if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-fi
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~x86"
-IUSE="debug"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
-"
-
-DEPEND="${PYTHON_DEPS}
- >=dev-python/PyQt5-5.15.5[gui,network,printsupport,ssl,webchannel,widgets,${PYTHON_USEDEP}]
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwebengine:5[widgets]
-"
-RDEPEND="${DEPEND}
- >=dev-python/PyQt5-sip-12.9:=[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/PyQt-builder-1.10[${PYTHON_USEDEP}]
- >=dev-python/sip-6.2[${PYTHON_USEDEP}]
- dev-qt/qtcore:5
-"
-
-src_configure() {
- configuration() {
- local myconf=(
- sip-build
- --verbose
- --build-dir="${BUILD_DIR}"
- --scripts-dir="$(python_get_scriptdir)"
- --qmake="$(qt5_get_bindir)"/qmake
- --no-make
- $(usev debug '--debug --qml-debug --tracing')
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- # Run eqmake to respect toolchain and build flags
- run_in_build_dir eqmake5 -recursive ${PN}.pro
- }
- python_foreach_impl configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake INSTALL_ROOT="${D}" install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- einstalldocs
-}