summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-31 10:39:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-31 11:21:01 +0200
commitd0e94a2ff1c10c28c6aeaadfefa119801f3e6ad3 (patch)
tree20b4af2344634d1d2ebbd35f0d32f8d008356873
parentdev-python/versioneer: Bump to 0.24 (diff)
downloadgentoo-d0e94a2f.tar.gz
gentoo-d0e94a2f.tar.bz2
gentoo-d0e94a2f.zip
dev-python/fsspec: Bump to 2022.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2022.8.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index c841bd8670da..a4e0c9a88d31 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
DIST filesystem_spec-2022.7.1.gh.tar.gz 338526 BLAKE2B ef19c41a4e9fe3fb1a5146967bab505c26590aa4c074152523b705d8cac5eeb6e30834e1adbbb1669f5bbb58891cabd3960208cdfa9f619e0bbc5cbfe5f4ef55 SHA512 07178bf22e07091935256296b303e273c03e2ddc15a5aa1110f84c27cadaf9c650204e37c472cb10280e92f24b01fa8b16fe32db21a30d14d232c5a11e05a45c
+DIST filesystem_spec-2022.8.0.gh.tar.gz 338839 BLAKE2B 6d70e20a435caab098db2437137fcd80efdcb08ff3018daf5c72ceb958fcca354eb6a12a525ea023fd042cf54099fe991a444c3627989bc3f0e38bddd8d57aca SHA512 843ee51d7dec362623ebe584def6bb7c8b5521434befd89bba178969bb9fbe53b9b488f0f8d301d600fe2f97e876a6b74f92c9d0e9b8941aaa70f5514e6516ee
diff --git a/dev-python/fsspec/fsspec-2022.8.0.ebuild b/dev-python/fsspec/fsspec-2022.8.0.ebuild
new file mode 100644
index 000000000000..dba46d7fc2e2
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2022.8.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+)
+
+EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+ # unhappy about dev-python/fuse-python (?)
+ fsspec/tests/test_fuse.py
+)