summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-22 15:46:42 +0000
committerSam James <sam@gentoo.org>2024-01-01 20:34:23 +0000
commitd0f22fafca63f78e83823ee61bceefed750b36d7 (patch)
tree5d4491d7f0a56cb4726d02f63c082408a1c0a64a
parentdev-util/itstool: Fix Handling of Untranslated Nodes (diff)
downloadgentoo-d0f22fafca63f78e83823ee61bceefed750b36d7.tar.gz
gentoo-d0f22fafca63f78e83823ee61bceefed750b36d7.tar.bz2
gentoo-d0f22fafca63f78e83823ee61bceefed750b36d7.zip
dev-libs/libmateweather: add 1.26.2, 1.27.1
Tests pass on both versions fixing #867271 Bumped versions fix missing weather data #917271 Closes: https://bugs.gentoo.org/916271 Closes: https://bugs.gentoo.org/867271 Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/libmateweather/Manifest2
-rw-r--r--dev-libs/libmateweather/libmateweather-1.26.2.ebuild48
-rw-r--r--dev-libs/libmateweather/libmateweather-1.27.1.ebuild48
3 files changed, 98 insertions, 0 deletions
diff --git a/dev-libs/libmateweather/Manifest b/dev-libs/libmateweather/Manifest
index 15f23c0ac215..908ee2e47b97 100644
--- a/dev-libs/libmateweather/Manifest
+++ b/dev-libs/libmateweather/Manifest
@@ -1,2 +1,4 @@
DIST libmateweather-1.26.0.tar.xz 2213064 BLAKE2B ae6670f60694627491890e3ff35550937f9b30431e3d6c48780e38c15a13d2a5812129e13c228f6a81004787e078ccc6c7410b75e17112f3afe993e5a7e061bd SHA512 e786071d8c9393abc6d8f0733bd213305ace50698066ba7913ac254d8944e6db94296de5ecf91c0d5a8babd38f0cc35cb3bcee046f1eb0339ec5429a66d062d1
DIST libmateweather-1.26.1.tar.xz 2207404 BLAKE2B 5a5f9804193a50209d3aedc34ba5e605a286445bff624a36db03b94a2c05bd89dbd5c1dc076a694004e90a6c37739ec6a923712504c3ed683480acde0efd6511 SHA512 98cf2363c0bc75341d206d8848484e44665a35e3f01e7f75510555ab341fe06a3c96ea8e1844b17d5da7bc5a172cb18b594c8edfeb28ca8e25a82149ae508748
+DIST libmateweather-1.26.2.tar.xz 2205160 BLAKE2B 125efc42a66277222ef5c1538231d01aaf1584ee9314312f98862f84db77b40b4b201bb76f36ec246ffd85863296a013128a0a74090904043a91702d6f91190e SHA512 fd91ae4d89c27163ab7b4c50db944338b584c8769ab6c548bdea14f1d06898e338a35cfa27a0e923a8fc9f05c3620675dd4f706ec47b49423e686e70f97c1384
+DIST libmateweather-1.27.1.tar.xz 2203672 BLAKE2B 16a1490eea8d608275b94622ed918332498ebecbe7ddc385095c7b953ed657ead142c4cb0aff8ac8624e6a4ab559e2e54b3e44be10e899889d390023710c0fe8 SHA512 4de78f57768681c77d85dd5cbbea68f4000e37a696b3bd01510a27dceb204b3425db257fe431461eb81fe85395f8c0e072c2821eb6337ef21067734e151a4fcc
diff --git a/dev-libs/libmateweather/libmateweather-1.26.2.ebuild b/dev-libs/libmateweather/libmateweather-1.26.2.ebuild
new file mode 100644
index 000000000000..badf1baf1e1c
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.26.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="LGPL-2.1+ GPL-2+"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.56:2
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.54:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml \
+ --disable-icon-update
+}
diff --git a/dev-libs/libmateweather/libmateweather-1.27.1.ebuild b/dev-libs/libmateweather/libmateweather-1.27.1.ebuild
new file mode 100644
index 000000000000..badf1baf1e1c
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.27.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="LGPL-2.1+ GPL-2+"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.56:2
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.54:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml \
+ --disable-icon-update
+}