summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-29 09:02:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-29 09:09:37 +0200
commitd0f568facac217405f5a092ed40783d8b7a33b8b (patch)
treea588b80f0cd8f114657274de806c8f35e1d7830c
parentsys-devel/gcc: really backport the -Wstringop-overflow fix to 12.x (diff)
downloadgentoo-d0f568facac217405f5a092ed40783d8b7a33b8b.tar.gz
gentoo-d0f568facac217405f5a092ed40783d8b7a33b8b.tar.bz2
gentoo-d0f568facac217405f5a092ed40783d8b7a33b8b.zip
xfce-extra/xfce4-netload-plugin: Bump to 1.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-netload-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.4.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-netload-plugin/Manifest b/xfce-extra/xfce4-netload-plugin/Manifest
index aa359b5a226c..595dab2d265f 100644
--- a/xfce-extra/xfce4-netload-plugin/Manifest
+++ b/xfce-extra/xfce4-netload-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-netload-plugin-1.4.0.tar.bz2 403719 BLAKE2B fc99c7128812208c82e88732dfa5ae0f315cc107e6a52f18dd6b47bf7693ac69f8948665a56af4bce722c078eb1f735ad00ce15def65ff77a696674ec6ae804c SHA512 b9740251a81382f25ed3c89f10e842ef5432e36696df304a2b038d4a0a0a8c49d9988fff5274f3421870afe4f8cca1755222d6e7c514cea51e6eea7235a00382
+DIST xfce4-netload-plugin-1.4.1.tar.bz2 421959 BLAKE2B 842f5fb8cb8f7cbe4c4fa80ec9ed7c67cead5e2f2cd444d3dca2f8d0dbc2e6b41fc22d08ec9893b10f5553fdfd7756a2afe95d40646f23e5c2f161127b747c11 SHA512 b860ab96e9a78099d0250f8bc5fe7a2e9fadaccf5edf6f67fa02a4c65ef0f1948fa8409506db873ff6a6fbfeb2df0c59fa1979b01ba6df5df6b645f4c842eeb9
diff --git a/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.4.1.ebuild b/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.4.1.ebuild
new file mode 100644
index 000000000000..ad87d386ee32
--- /dev/null
+++ b/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A network load plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-netload-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-netload-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}