summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-30 23:59:37 +0000
committerSam James <sam@gentoo.org>2020-08-30 23:59:37 +0000
commitd11def5add7f91de78cff2230113e153cd8b6472 (patch)
tree4885bb0250cfab813fe3522ad7aa4a31e6c50b58
parentapp-crypt/gpgme: Stabilize 1.14.0 arm, #710206 (diff)
downloadgentoo-d11def5a.tar.gz
gentoo-d11def5a.tar.bz2
gentoo-d11def5a.zip
net-wireless/wireless-tools: cleanup EAPI 4
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-wireless/wireless-tools/wireless-tools-30_pre9.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/net-wireless/wireless-tools/wireless-tools-30_pre9.ebuild b/net-wireless/wireless-tools/wireless-tools-30_pre9.ebuild
deleted file mode 100644
index 0d412dd1f216..000000000000
--- a/net-wireless/wireless-tools/wireless-tools-30_pre9.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit toolchain-funcs multilib eutils
-
-# The following works with both pre-releases and releases
-MY_P=${PN/-/_}.${PV/_/.}
-S="${WORKDIR}/${MY_P/\.pre*/}"
-
-DESCRIPTION="A collection of tools to configure IEEE 802.11 wireless LAN cards"
-HOMEPAGE="http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html"
-SRC_URI="http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~sparc x86"
-IUSE="multicall"
-
-DEPEND="sys-apps/sed"
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-29-asneeded.patch
-
- sed -i \
- -e "s:^\(CC\) = gcc:\1 = $(tc-getCC):" \
- -e "s:^\(AR\) = ar:\1 = $(tc-getAR):" \
- -e "s:^\(RANLIB\) = ranlib:\1 = $(tc-getRANLIB):" \
- -e "s:^\(CFLAGS=-Os\):#\1:" \
- -e "s:\(@\$(LDCONFIG).*\):#\1:" \
- -e "s:^\(INSTALL_MAN= \$(PREFIX)\)/man:\1/usr/share/man:" \
- -e "s:^\(INSTALL_LIB= \$(PREFIX)\)/lib:\1/$(get_libdir)/:" \
- -e "s:^\(INSTALL_INC= \$(PREFIX)\)/include:\1/usr/include:" \
- -e "s:^\(BUILD_STATIC = y\):#\1:" \
- -e '/\$(CC)/s:-Wl,-s\>::' \
- "${S}"/Makefile || die
-}
-
-src_compile() {
- emake
-
- use multicall && emake iwmulticall
-}
-
-src_install() {
- emake PREFIX="${ED}" install
-
- if use multicall; then
- # 'make install-iwmulticall' will overwrite some of the tools
- # with symlinks - this is intentional (brix)
- emake PREFIX="${ED}" install-iwmulticall
- fi
-
- has cs ${LINGUAS-cs} || rm -rf "${ED}"/usr/share/man/cs
- has fr ${LINGUAS-fr} || rm -rf "${ED}"/usr/share/man/fr.{ISO8859-1,UTF-8}
-
- dodoc CHANGELOG.h HOTPLUG-UDEV.txt IFRENAME-VS-XXX.txt PCMCIA.txt README
- has fr ${LINGUAS-fr} && dodoc README.fr
-}