summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2017-02-06 17:56:19 +0100
committerGöktürk Yüksek <gokturk@gentoo.org>2017-02-06 15:14:07 -0500
commitd129ea33d6a956dfaded0e3fa093fc102067cb7c (patch)
tree6b6793b999ae9379a04d6b604c4552121ae50d39
parentdev-libs/libassuan: fix configure standards conflict on Solaris (diff)
downloadgentoo-d129ea33d6a956dfaded0e3fa093fc102067cb7c.tar.gz
gentoo-d129ea33d6a956dfaded0e3fa093fc102067cb7c.tar.bz2
gentoo-d129ea33d6a956dfaded0e3fa093fc102067cb7c.zip
sys-apps/tuxonice-userui: remove unused patches
-rw-r--r--sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch45
-rw-r--r--sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-libpng15.patch88
2 files changed, 0 insertions, 133 deletions
diff --git a/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch
deleted file mode 100644
index 8cc315f92082..000000000000
--- a/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -Nru tuxonice-userui-1.0.vanilla/Makefile tuxonice-userui-1.0/Makefile
---- tuxonice-userui-1.0.vanilla/Makefile 2009-04-04 13:37:13.000000000 +0200
-+++ tuxonice-userui-1.0/Makefile 2009-04-05 14:13:23.000000000 +0200
-@@ -32,15 +32,15 @@
- all: $(TARGETS)
-
- fbsplash:
-- make -C $@ all
-+ $(MAKE) -C $@ all
-
- usplash:
-- make -C $@ all
-+ $(MAKE) -C $@ all
-
- tuxoniceui_text: $(CORE_OBJECTS) userui_text.o
- $(CC) $(LDFLAGS) -static $^ -o $@
-
--tuxoniceui_fbsplash: fbsplash $(CORE_OBJECTS) fbsplash/userui_fbsplash.o
-+tuxoniceui_fbsplash: fbsplash $(CORE_OBJECTS)
- $(CC) $(LDFLAGS) -static $(CORE_OBJECTS) fbsplash/userui_fbsplash.o -o $@ $(FBSPLASH_LIBS)
-
- tuxoniceui_usplash: usplash $(CORE_OBJECTS) usplash/userui_usplash.o
-@@ -48,8 +48,8 @@
-
- clean:
- $(RM) *.o $(TARGETS)
-- make -C fbsplash clean
-- make -C usplash clean
-+ $(MAKE) -C fbsplash clean
-+ $(MAKE) -C usplash clean
-
- $(INSTDIR)/%: %
- strip $<
-diff -Nru tuxonice-userui-1.0.vanilla/fbsplash/Makefile tuxonice-userui-1.0/fbsplash/Makefile
---- tuxonice-userui-1.0.vanilla/fbsplash/Makefile 2009-04-04 13:37:13.000000000 +0200
-+++ tuxonice-userui-1.0/fbsplash/Makefile 2009-04-05 14:14:53.000000000 +0200
-@@ -6,7 +6,7 @@
- parse.o mng_callbacks.o mng_render.o render.o ttf.o
- SOURCES = $(patsubst %.o,%.c,$(OBJECTS))
-
--all: $(TARGET)
-+all: $(TARGET) $(OBJECTS)
-
- userui_fbsplash.o: $(OBJECTS)
- $(CC) $(LDFLAGS) -r -nostdlib -nostartfiles $(SPLASH_LDLIBS) $^ -o $@
diff --git a/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-libpng15.patch b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-libpng15.patch
deleted file mode 100644
index bfe6d0a5e50e..000000000000
--- a/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-libpng15.patch
+++ /dev/null
@@ -1,88 +0,0 @@
---- fbsplash/image.c
-+++ fbsplash/image.c
-@@ -112,29 +112,29 @@
- png_init_io(png_ptr, fp);
- png_read_info(png_ptr, info_ptr);
-
-- if (cmap && info_ptr->color_type != PNG_COLOR_TYPE_PALETTE) {
-+ if (cmap && png_get_color_type(png_ptr, info_ptr) != PNG_COLOR_TYPE_PALETTE) {
- printerr("Could not read file %s. Not a palette-based image.\n", filename);
- goto failed;
- }
-
-- if (info_ptr->color_type == PNG_COLOR_TYPE_GRAY ||
-- info_ptr->color_type == PNG_COLOR_TYPE_GRAY_ALPHA)
-+ if (png_get_color_type(png_ptr, info_ptr) == PNG_COLOR_TYPE_GRAY ||
-+ png_get_color_type(png_ptr, info_ptr) == PNG_COLOR_TYPE_GRAY_ALPHA)
- png_set_gray_to_rgb(png_ptr);
-
-- if (info_ptr->bit_depth == 16)
-+ if (png_get_bit_depth(png_ptr, info_ptr) == 16)
- png_set_strip_16(png_ptr);
-
-- if (!want_alpha && info_ptr->color_type & PNG_COLOR_MASK_ALPHA)
-+ if (!want_alpha && png_get_color_type(png_ptr, info_ptr) & PNG_COLOR_MASK_ALPHA)
- png_set_strip_alpha(png_ptr);
-
- #ifndef TARGET_KERNEL
-- if (!(info_ptr->color_type & PNG_COLOR_MASK_ALPHA) & want_alpha) {
-+ if (!(png_get_color_type(png_ptr, info_ptr) & PNG_COLOR_MASK_ALPHA) & want_alpha) {
- png_set_add_alpha(png_ptr, 0xff, PNG_FILLER_AFTER);
- }
- #endif
- png_read_update_info(png_ptr, info_ptr);
-
-- if (!cmap && info_ptr->color_type != PNG_COLOR_TYPE_RGB && info_ptr->color_type != PNG_COLOR_TYPE_RGBA) {
-+ if (!cmap && png_get_color_type(png_ptr, info_ptr) != PNG_COLOR_TYPE_RGB && png_get_color_type(png_ptr, info_ptr) != PNG_COLOR_TYPE_RGBA) {
- printerr("Could not read file %s. Not an RGB image.\n", filename);
- goto failed;
- }
-@@ -150,12 +150,12 @@
-
- rowbytes = png_get_rowbytes(png_ptr, info_ptr);
-
-- if ((width && *width && info_ptr->width != *width) || (height && *height && info_ptr->height != *height)) {
-+ if ((width && *width && png_get_image_width(png_ptr, info_ptr) != *width) || (height && *height && png_get_image_height(png_ptr, info_ptr) != *height)) {
- printerr("Image size mismatch: %s.\n", filename);
- goto failed;
- } else {
-- *width = info_ptr->width;
-- *height = info_ptr->height;
-+ *width = png_get_image_width(png_ptr, info_ptr);
-+ *height = png_get_image_height(png_ptr, info_ptr);
- }
-
- *data = malloc(fb_var.xres * fb_var.yres * bytespp);
-@@ -171,11 +171,11 @@
- goto failed;
- }
-
-- for (i = 0; i < info_ptr->height; i++) {
-+ for (i = 0; i < png_get_image_height(png_ptr, info_ptr); i++) {
- if (cmap) {
-- row_pointer = *data + info_ptr->width * i;
-+ row_pointer = *data + png_get_image_width(png_ptr, info_ptr) * i;
- } else if (want_alpha) {
-- row_pointer = *data + info_ptr->width * i * 4;
-+ row_pointer = *data + png_get_image_width(png_ptr, info_ptr) * i * 4;
- } else {
- row_pointer = buf;
- }
-@@ -184,7 +184,7 @@
-
- if (cmap) {
- int h = 256 - cmap->len;
-- t = *data + info_ptr->width * i;
-+ t = *data + png_get_image_width(png_ptr, info_ptr) * i;
-
- if (h) {
- /* Move the colors up by 'h' offset. This is used because fbcon
-@@ -196,7 +196,7 @@
-
- /* We only need to convert the image if we the alpha channel is not required */
- } else if (!want_alpha) {
-- truecolor2fb((truecolor*)buf, *data + info_ptr->width * bytespp * i, info_ptr->width, i, 0);
-+ truecolor2fb((truecolor*)buf, *data + png_get_image_width(png_ptr, info_ptr) * bytespp * i, png_get_image_width(png_ptr, info_ptr), i, 0);
- }
- }
-