summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2022-09-14 23:13:52 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2022-09-14 23:20:39 +0300
commitd133328a074da76a1f0172968f5fb360453bf725 (patch)
treed3f88a01bdf2818101c97aa7d66338b46b24908d
parentapp-cdr/isoimagewriter: Add missing dependency (diff)
downloadgentoo-d133328a074da76a1f0172968f5fb360453bf725.tar.gz
gentoo-d133328a074da76a1f0172968f5fb360453bf725.tar.bz2
gentoo-d133328a074da76a1f0172968f5fb360453bf725.zip
dev-embedded/platformio: Add udev_reload
Closes: https://bugs.gentoo.org/842096 Signed-off-by: Alexey Shvetsov (Alexey Shvetsov) <alexxy@gentoo.org>
-rw-r--r--dev-embedded/platformio/Manifest1
-rw-r--r--dev-embedded/platformio/platformio-5.2.5-r2.ebuild87
-rw-r--r--dev-embedded/platformio/platformio-6.0.2-r1.ebuild (renamed from dev-embedded/platformio/platformio-6.0.2.ebuild)8
3 files changed, 8 insertions, 88 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
index 51724e0adc5b..9756ab40a050 100644
--- a/dev-embedded/platformio/Manifest
+++ b/dev-embedded/platformio/Manifest
@@ -1,2 +1 @@
-DIST platformio-5.2.5.tar.gz 254813 BLAKE2B 96911a64f8e73567820ef2c7b2297ed9e32c36c65c49572af6037c2666da4072bdf920dc31e8de7e07296eb7f1b407c47191d68a80ed212a9c351dfca604b408 SHA512 cf939254c231bb2cb97ac509175b7235a6a2ba447e55a2d9a59a9fe610656743c190f00cb7bfa1fc2e6b64487be7f02a193e2f270236bbb9200537f19175dc22
DIST platformio-6.0.2.tar.gz 285452 BLAKE2B c70523837b5118fcc1209a36a425fb6ab0aac73e56732916ff3d39fe87d50a47bf7d31d77324f491093ed366b1b3e4f88274e973bc896b164f5a07687a53bd12 SHA512 a2e48ad9ca22024a06509a9e36e5a7586088d0e8abd67d309d1988a8a112a41e301f077f1b466b5db390dc4048add570acd5bb762bbf22db69715dead0d8fc89
diff --git a/dev-embedded/platformio/platformio-5.2.5-r2.ebuild b/dev-embedded/platformio/platformio-5.2.5-r2.ebuild
deleted file mode 100644
index 9c0cbfa5bbd5..000000000000
--- a/dev-embedded/platformio/platformio-5.2.5-r2.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8,9,10} )
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1 udev
-
-DESCRIPTION="An open source ecosystem for IoT development"
-HOMEPAGE="https://platformio.org/"
-SRC_URI="https://github.com/platformio/platformio-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-core-${PV}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- <dev-python/aiofiles-0.9[${PYTHON_USEDEP}]
- dev-python/ajsonrpc[${PYTHON_USEDEP}]
- <dev-python/bottle-0.13[${PYTHON_USEDEP}]
- >=dev-python/click-8[${PYTHON_USEDEP}]
- <dev-python/click-9[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/pyserial-3[${PYTHON_USEDEP}]
- <dev-python/pyserial-4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4[${PYTHON_USEDEP}]
- <dev-python/requests-3[${PYTHON_USEDEP}]
- >=dev-python/semantic_version-2.9[${PYTHON_USEDEP}]
- <dev-python/semantic_version-3[${PYTHON_USEDEP}]
- >=dev-python/tabulate-0.8.3[${PYTHON_USEDEP}]
- <dev-python/tabulate-1[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- >=dev-python/pyelftools-0.25[${PYTHON_USEDEP}]
- <dev-python/pyelftools-1[${PYTHON_USEDEP}]
- >=dev-python/marshmallow-2.20.5[${PYTHON_USEDEP}]
- =dev-python/starlette-0.18*[${PYTHON_USEDEP}]
- =dev-python/uvicorn-0.17*[${PYTHON_USEDEP}]
- dev-python/wsproto[${PYTHON_USEDEP}]
- >=dev-python/zeroconf-0.37[${PYTHON_USEDEP}]
- ')
- virtual/udev"
-DEPEND="virtual/udev"
-BDEPEND="test? ( $(python_gen_cond_dep 'dev-python/jsondiff[${PYTHON_USEDEP}]') )"
-
-# This list could be refined a bit to have individual tests which need network
-# (within EPYTEST_DESELECT) but so many need it that it doesn't seem worth it right now.
-EPYTEST_IGNORE=(
- # Requires network access
- tests/test_builder.py
- tests/package/test_manager.py
- tests/package/test_manifest.py
- tests/commands/test_platform.py
- tests/commands/test_test.py
- tests/commands/test_ci.py
- tests/commands/test_init.py
- tests/commands/test_lib.py
- tests/commands/test_lib_complex.py
- tests/commands/test_boards.py
- tests/commands/test_check.py
- tests/test_ino2cpp.py
- tests/test_maintenance.py
- tests/test_misc.py
-)
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.2.5-fix-semantic-version-dep.patch
-)
-
-src_prepare() {
- # Allow newer versions of zeroconf, Bug #831181.
- # Also wsproto.
- sed -e '/zeroconf/s/==[0-9.*]*//' \
- -e '/wsproto/s/==[0-9.*]*//' \
- -i setup.py || die
- default
-}
-
-src_install() {
- distutils-r1_src_install
- udev_dorules scripts/99-platformio-udev.rules
-}
diff --git a/dev-embedded/platformio/platformio-6.0.2.ebuild b/dev-embedded/platformio/platformio-6.0.2-r1.ebuild
index bf24334631e4..827140a1feaa 100644
--- a/dev-embedded/platformio/platformio-6.0.2.ebuild
+++ b/dev-embedded/platformio/platformio-6.0.2-r1.ebuild
@@ -106,3 +106,11 @@ src_install() {
distutils-r1_src_install
udev_dorules scripts/99-platformio-udev.rules
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}