summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:42:32 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:42:32 -0600
commitd133574aa6a6d9eabf9c95e07793df649d64f541 (patch)
treeb43780d5d6a75397d9ea35820b4d69c25569e72f
parentdev-python/WSME: bup (diff)
downloadgentoo-d133574a.tar.gz
gentoo-d133574a.tar.bz2
gentoo-d133574a.zip
dev-python/glance_store: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/glance_store/Manifest1
-rw-r--r--dev-python/glance_store/glance_store-0.20.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/glance_store/Manifest b/dev-python/glance_store/Manifest
index 05591acf4449..4c866a0331a9 100644
--- a/dev-python/glance_store/Manifest
+++ b/dev-python/glance_store/Manifest
@@ -1,2 +1,3 @@
DIST glance_store-0.13.1.tar.gz 127250 SHA256 e2f2051ff22abaa462fdb7fe8741312de8543bba7f6f65165b9c52343ccd35fc SHA512 1625849ed35d8fec6d730790485451fd740240a6fd076ad084cd0444b5b8bfadeab82164854a9bee194f6f3cabff7c30815d5fdcd800a7d982ed8c3224e6aaec WHIRLPOOL e16ad3aef7ca1ef15ead956fa7e459a4f6259b3c7ffb0086b11aa5fe2c4034011d306df09255cf6b94bf9474861546e483147c3823d804b661244455e463a217
DIST glance_store-0.18.0.tar.gz 126949 SHA256 56b8b33f5deb74c652bd82d781aa82459e14152a5ee5c74726f0f1545c2355a7 SHA512 f23505b0081d0bb9948a4a2550868ea9864c00604358264c826551caccb4e35cbdcfcaa1e0ed3d470fbe72250196e246b596cbb57db0e99cc49fba3e0c609e01 WHIRLPOOL a1f26bc06a19a6deb14b910813829a07726ec9408b71e4fbb854ea3a2815f872cd27dfd82ae4f84e1bf49fdf5b89ef079c8f17f24a883bbf5a2cacc218f0ce8f
+DIST glance_store-0.20.0.tar.gz 129769 SHA256 9109738038f22fc229eb83698251c7d3086cf227922e7e3625d8d204986d818c SHA512 456a316763b2364747d24472aa42cf7602d3432043a52164a141ea0827afd2c92e6770a4c04ca7bb3c96cb9103080801cb1095a1869e5851c0ee83c4e7aea018 WHIRLPOOL 47f2f968d228038c69d6510a9845e6789369283c29c25b9f0babae9d50090034f40665f89421cb94f378b7ad147d03ed5516a84b29645ccca18d4c4a994017f5
diff --git a/dev-python/glance_store/glance_store-0.20.0.ebuild b/dev-python/glance_store/glance_store-0.20.0.ebuild
new file mode 100644
index 000000000000..86fab2e44741
--- /dev/null
+++ b/dev-python/glance_store/glance_store-0.20.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for glance"
+HOMEPAGE="https://github.com/openstack/glance_store"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+cinder"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.17.1[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.0[${PYTHON_USEDEP}]
+ cinder? ( >=dev-python/python-cinderclient-1.2.1[${PYTHON_USEDEP}] )
+"