summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-04-20 12:05:18 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-04-20 12:19:38 +0200
commitd13e8c2a91c13a6e1c95cf727e78fef2aa2bb2ec (patch)
treea3ab1a8732c6055e3becd6df6093dabec2560e0e
parentdev-python/packaging: s390 stable wrt bug #716404 (diff)
downloadgentoo-d13e8c2a.tar.gz
gentoo-d13e8c2a.tar.bz2
gentoo-d13e8c2a.zip
net-misc/whois: Revbump to fix automagic dep on sys-libs/libxcrypt
Thanks-to: Eugene Shalygin <eugene.shalygin@gmail.com> Closes: https://bugs.gentoo.org/718104 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-misc/whois/files/whois-5.5.6-libxcrypt_automagic.patch19
-rw-r--r--net-misc/whois/metadata.xml3
-rw-r--r--net-misc/whois/whois-5.5.6-r1.ebuild (renamed from net-misc/whois/whois-5.5.6.ebuild)11
-rw-r--r--net-misc/whois/whois-9999.ebuild11
-rw-r--r--profiles/arch/alpha/package.use.mask4
-rw-r--r--profiles/arch/arm/package.use.mask4
-rw-r--r--profiles/arch/arm64/package.use.mask4
-rw-r--r--profiles/arch/ia64/package.use.mask4
-rw-r--r--profiles/arch/powerpc/package.use.mask4
9 files changed, 58 insertions, 6 deletions
diff --git a/net-misc/whois/files/whois-5.5.6-libxcrypt_automagic.patch b/net-misc/whois/files/whois-5.5.6-libxcrypt_automagic.patch
new file mode 100644
index 000000000000..f7bafd513dd4
--- /dev/null
+++ b/net-misc/whois/files/whois-5.5.6-libxcrypt_automagic.patch
@@ -0,0 +1,19 @@
+We don't want libxcrypt being detected automagically.
+Reverting upstream stupidity.
+
+--- whois-5.5.6/Makefile
++++ whois-5.5.6/Makefile
+@@ -55,12 +55,9 @@
+ DEFS += -DHAVE_ICONV
+ endif
+
+-ifeq ($(shell $(PKG_CONFIG) --exists 'libxcrypt >= 4.1' || echo NO),)
++ifdef HAVE_XCRYPT
+ DEFS += -DHAVE_CRYPT_H -DHAVE_LINUX_CRYPT_GENSALT $(shell $(PKG_CONFIG) --cflags libcrypt)
+ mkpasswd_LDADD += $(shell $(PKG_CONFIG) --libs libcrypt)
+-else ifdef HAVE_XCRYPT
+-DEFS += -DHAVE_XCRYPT_H -DHAVE_LINUX_CRYPT_GENSALT
+-mkpasswd_LDADD += -lxcrypt
+ else ifdef HAVE_LIBOWCRYPT
+ # owl and openSUSE have crypt_gensalt(3) in libowcrypt
+ DEFS += -DHAVE_CRYPT_H -DHAVE_LINUX_CRYPT_GENSALT -D_OW_SOURCE
diff --git a/net-misc/whois/metadata.xml b/net-misc/whois/metadata.xml
index fcd1dc3acbf9..742ee751212e 100644
--- a/net-misc/whois/metadata.xml
+++ b/net-misc/whois/metadata.xml
@@ -5,6 +5,9 @@
<email>base-system@gentoo.org</email>
<name>Gentoo Base System</name>
</maintainer>
+ <use>
+ <flag name="xcrypt">Enable crypt through <pkg>sys-libs/libxcrypt</pkg> package</flag>
+ </use>
<upstream>
<remote-id type="github">rfc1036/whois</remote-id>
</upstream>
diff --git a/net-misc/whois/whois-5.5.6.ebuild b/net-misc/whois/whois-5.5.6-r1.ebuild
index d99078f32be7..33c2eb43e69e 100644
--- a/net-misc/whois/whois-5.5.6.ebuild
+++ b/net-misc/whois/whois-5.5.6-r1.ebuild
@@ -18,12 +18,15 @@ else
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="iconv idn nls"
+IUSE="iconv idn nls xcrypt"
RESTRICT="test" #59327
-RDEPEND="iconv? ( virtual/libiconv )
+RDEPEND="
+ iconv? ( virtual/libiconv )
idn? ( net-dns/libidn2:= )
- nls? ( virtual/libintl )"
+ nls? ( virtual/libintl )
+ xcrypt? ( >=sys-libs/libxcrypt-4.1 )
+"
DEPEND="${RDEPEND}"
BDEPEND="
app-arch/xz-utils
@@ -36,6 +39,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-4.7.2-config-file.patch
"${FILESDIR}"/${PN}-5.3.0-libidn_automagic.patch
+ "${FILESDIR}"/${PN}-5.5.6-libxcrypt_automagic.patch
)
src_prepare() {
@@ -57,6 +61,7 @@ src_compile() {
unset HAVE_ICONV HAVE_LIBIDN
use iconv && export HAVE_ICONV=1
use idn && export HAVE_LIBIDN=1
+ use xcrypt && export HAVE_XCRYPT=1
tc-export CC
emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
}
diff --git a/net-misc/whois/whois-9999.ebuild b/net-misc/whois/whois-9999.ebuild
index 84b8abe1134b..8aecce2f7642 100644
--- a/net-misc/whois/whois-9999.ebuild
+++ b/net-misc/whois/whois-9999.ebuild
@@ -18,12 +18,15 @@ else
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="iconv idn nls"
+IUSE="iconv idn nls xcrypt"
RESTRICT="test" #59327
-RDEPEND="iconv? ( virtual/libiconv )
+RDEPEND="
+ iconv? ( virtual/libiconv )
idn? ( net-dns/libidn2:= )
- nls? ( virtual/libintl )"
+ nls? ( virtual/libintl )
+ xcrypt? ( >=sys-libs/libxcrypt-4.1 )
+"
DEPEND="${RDEPEND}"
BDEPEND="
app-arch/xz-utils
@@ -34,6 +37,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-4.7.2-config-file.patch
"${FILESDIR}"/${PN}-5.3.0-libidn_automagic.patch
+ "${FILESDIR}"/${PN}-5.5.6-libxcrypt_automagic.patch
)
src_prepare() {
@@ -55,6 +59,7 @@ src_compile() {
unset HAVE_ICONV HAVE_LIBIDN
use iconv && export HAVE_ICONV=1
use idn && export HAVE_LIBIDN=1
+ use xcrypt && export HAVE_XCRYPT=1
tc-export CC
emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
}
diff --git a/profiles/arch/alpha/package.use.mask b/profiles/arch/alpha/package.use.mask
index 496b26593821..25829fd47121 100644
--- a/profiles/arch/alpha/package.use.mask
+++ b/profiles/arch/alpha/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
+# Not keyworded on alpha
+net-misc/whois xcrypt
+
# Matt Turner <mattst88@gentoo.org> (2020-03-17)
# Requires an insane (and always growing) number of ruby deps
sys-block/thin-provisioning-tools test
diff --git a/profiles/arch/arm/package.use.mask b/profiles/arch/arm/package.use.mask
index f849b05335f3..28cd67fcbe8c 100644
--- a/profiles/arch/arm/package.use.mask
+++ b/profiles/arch/arm/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
+# Not keyworded on arm
+net-misc/whois xcrypt
+
# Ettore Di Giacinto <mudler@gentoo.org> (2016-11-10)
# Dependency has no stable keyword
# and as for now we have only stable mate versions
diff --git a/profiles/arch/arm64/package.use.mask b/profiles/arch/arm64/package.use.mask
index 510914431892..97105c1da2ff 100644
--- a/profiles/arch/arm64/package.use.mask
+++ b/profiles/arch/arm64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
+# Not keyworded on arm64
+net-misc/whois xcrypt
+
# Ettore Di Giacinto <mudler@gentoo.org> (2016-11-10)
# Dependency has no stable keyword
# and as for now we have only stable mate versions
diff --git a/profiles/arch/ia64/package.use.mask b/profiles/arch/ia64/package.use.mask
index c69d8ff9c590..871580a53b78 100644
--- a/profiles/arch/ia64/package.use.mask
+++ b/profiles/arch/ia64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
+# Not keyworded on ia64
+net-misc/whois xcrypt
+
# Mikle Kolyada <zlogene@gentoo.org> (2020-04-20)
# dev-lang/ruby is not keyworded (a dep)
app-text/texlive context l10n_ja
diff --git a/profiles/arch/powerpc/package.use.mask b/profiles/arch/powerpc/package.use.mask
index 02e846ab33f3..7f4e68052f34 100644
--- a/profiles/arch/powerpc/package.use.mask
+++ b/profiles/arch/powerpc/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
+# Not keyworded on ppc
+net-misc/whois xcrypt
+
# Patrick McLean <chutzpah@gentoo.org> (2020-04-03)
# Lots of deps for little gain
dev-python/joblib doc