summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-02 23:47:16 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-02 23:47:16 +0200
commitd14634fca4bcffb64c6f3ba227df9ee35505c20c (patch)
tree484ddd9e516e59b511e6ea6a6cc1cdb0349a459e
parentnet-misc/freerdp: drop 2.4.1-r1, 2.5.0, 2.5.0_p39 (diff)
downloadgentoo-d14634fca4bcffb64c6f3ba227df9ee35505c20c.tar.gz
gentoo-d14634fca4bcffb64c6f3ba227df9ee35505c20c.tar.bz2
gentoo-d14634fca4bcffb64c6f3ba227df9ee35505c20c.zip
dev-libs/link-grammar: drop 5.10.2
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-libs/link-grammar/Manifest1
-rw-r--r--dev-libs/link-grammar/files/link-grammar-5.10.2-musl.patch13
-rw-r--r--dev-libs/link-grammar/link-grammar-5.10.2.ebuild116
3 files changed, 0 insertions, 130 deletions
diff --git a/dev-libs/link-grammar/Manifest b/dev-libs/link-grammar/Manifest
index 3a97a6932144..a09777eb5c2c 100644
--- a/dev-libs/link-grammar/Manifest
+++ b/dev-libs/link-grammar/Manifest
@@ -1,2 +1 @@
-DIST link-grammar-5.10.2.tar.gz 3853934 BLAKE2B d2cb64a6b0146f40ce5b197c21ded94f1256360615c2332a1c546f6b6c71c98d2500e97b0fcabae964377a04143fa13ba3af324f2de729cfccd280e53f6fb7c3 SHA512 71bc881cb628fe1898403024d8e949b2fbf44f5d20445f6fff7bb6038646840556d734434beb7eb43b63f661e18333657deaeb1b8c96b50d5fe3b6ef727565c2
DIST link-grammar-5.10.4.tar.gz 4593602 BLAKE2B 0515aed27ae8df85ceddb9685ce90db2b6e7671235b9b445b6728b1ac417d6d43b3705566066ff9735fc98c32746342c224f2399bb0f2573784f20b5f998e7be SHA512 a215694f76e15286c478884ea8a13b32976d06ea45d10897dc1b303f256a2c0af94c9f90da26b314ce5e03009b494ab526c729b66f2b1ed46ff3e8b02cb6fd08
diff --git a/dev-libs/link-grammar/files/link-grammar-5.10.2-musl.patch b/dev-libs/link-grammar/files/link-grammar-5.10.2-musl.patch
deleted file mode 100644
index 8015e3ceb1e4..000000000000
--- a/dev-libs/link-grammar/files/link-grammar-5.10.2-musl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/link-grammar/minisat/minisat/utils/System.h
-+++ b/link-grammar/minisat/minisat/utils/System.h
-@@ -21,10 +21,6 @@
- #ifndef Minisat_System_h
- #define Minisat_System_h
-
--#if defined(__linux__)
--#include <fpu_control.h>
--#endif
--
- #include "minisat/mtl/IntTypes.h"
-
- //-------------------------------------------------------------------------------------------------
diff --git a/dev-libs/link-grammar/link-grammar-5.10.2.ebuild b/dev-libs/link-grammar/link-grammar-5.10.2.ebuild
deleted file mode 100644
index 2d703fde38ff..000000000000
--- a/dev-libs/link-grammar/link-grammar-5.10.2.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit autotools python-r1 out-of-source
-
-DESCRIPTION="A Syntactic English parser"
-HOMEPAGE="https://www.abisource.com/projects/link-grammar/ https://www.link.cs.cmu.edu/link/"
-SRC_URI="https://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/5"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv sparc ~x86"
-IUSE="aspell +hunspell python" # pcre
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-# XXX: sqlite is automagic
-# Does not build with >=sci-mathematics/minisat-2, bug #593662
-# add pcre support: pcre? ( dev-libs/libpcre )
-RDEPEND="
- dev-db/sqlite:3
- aspell? ( app-text/aspell )
- hunspell? ( app-text/hunspell )
- python? ( ${PYTHON_DEPS} )
- !sci-mathematics/minisat"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-lang/swig:0
- sys-devel/autoconf-archive
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.8.1-lld.patch
- "${FILESDIR}"/${P}-musl.patch
-)
-
-pkg_setup() {
- if use aspell && use hunspell; then
- ewarn "You have enabled 'aspell' and 'hunspell' support, but both cannot coexist,"
- ewarn "only hunspell will be built. Press Ctrl+C and set only 'aspell' USE flag if"
- ewarn "you want aspell support."
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-my_src_configure() {
- local myconf=(
- --disable-maintainer-mode
- --disable-editline
- # java is hopelessly broken, invokes maven at build time (bug #806157)
- --disable-java-bindings
- --disable-perl-bindings
- --disable-static
- --enable-sat-solver=bundled
- $(use_enable aspell)
- $(use_enable hunspell)
- $(usev hunspell --with-hunspell-dictdir="${EPREFIX}"/usr/share/myspell)
- # $(use_enable pcre regex-tokenizer)
- # $(use_with pcre)
- )
-
- econf \
- --disable-python-bindings \
- "${myconf[@]}"
-
- if use python; then
- python_configure() {
- econf \
- --enable-python-bindings \
- "${myconf[@]}"
- }
- python_foreach_impl run_in_build_dir python_configure
- fi
-}
-
-my_src_compile() {
- local -x MAIN_BUILD_DIR="${BUILD_DIR}"
- default
-
- if use python; then
- python_compile() {
- emake -C bindings/python \
- VPATH="${S}:${MAIN_BUILD_DIR}" \
- _clinkgrammar_la_DEPENDENCIES="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
- _clinkgrammar_la_LIBADD="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la
- }
- python_foreach_impl run_in_build_dir python_compile
- fi
-}
-
-my_src_install() {
- local -x MAIN_BUILD_DIR="${BUILD_DIR}"
- default
-
- if use python; then
- python_install() {
- emake -C bindings/python \
- VPATH="${S}:${MAIN_BUILD_DIR}" \
- _clinkgrammar_la_DEPENDENCIES="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
- _clinkgrammar_la_LIBADD="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
- DESTDIR="${D}" \
- install
- }
- python_foreach_impl run_in_build_dir python_install
- fi
-
- # no static archives
- find "${ED}" -name '*.la' -delete || die
-}