summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-23 11:06:31 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-23 11:12:47 +0200
commitd14dd7b552d1ee8278d4c2014454affb225a018c (patch)
treeece908f868d1b4ad89c216b45afac97307d05548
parentdev-perl/Class-Virtual: Bump to version 0.70.0 (diff)
downloadgentoo-d14dd7b5.tar.gz
gentoo-d14dd7b5.tar.bz2
gentoo-d14dd7b5.zip
x11-apps/xkbset: Add Debian patch.
Package-Manager: portage-2.3.0
-rw-r--r--x11-apps/xkbset/Manifest1
-rw-r--r--x11-apps/xkbset/files/xkbset-0.5-ldflags.patch4
-rw-r--r--x11-apps/xkbset/xkbset-0.5_p5_p1.ebuild53
3 files changed, 56 insertions, 2 deletions
diff --git a/x11-apps/xkbset/Manifest b/x11-apps/xkbset/Manifest
index 9647eccd8e29..bbd57744889b 100644
--- a/x11-apps/xkbset/Manifest
+++ b/x11-apps/xkbset/Manifest
@@ -1 +1,2 @@
DIST xkbset-0.5.tar.gz 13933 SHA256 01c2579495b39e00d870f50225c441888dc88021e9ee3b693a842dd72554d172 SHA512 64de1a18076c0e0fd3e3189444b6033880028f53777566286caf935bfafcf062ccbd408d20926e2a4febb77d15b026349e0288f2aa93c815ddd9437b96589d8c WHIRLPOOL 225d5f0e35ed7efb7c6b122f87d607ba25dd5f3bf92e9daea1a580f7b488f7ad2141c57d755fbdda8c723de4d4c482846448ab341ebbec96bb0e118a713a946c
+DIST xkbset_0.5-5.1.diff.gz 3744 SHA256 a50a099c79d6bfed830e98b7797b3adfe31fe4480cc20d3d31a7a363db2995ee SHA512 92c362653088d5249dc26959cc898d4f8882f77b410ae09bbb2f03972940ed64ee2864b6da3425692c5cfa2bfe3b34d8316f5d7aa619f25c6311ac7a91a8db4b WHIRLPOOL d87e38c617e1eb0981f6e98929b1e2d94395b5f14f2dc7daa6bcdcd64bcf8c692058295a59b020dcb22cdc01fd594ea83b2446176978f57b7402083ff853531d
diff --git a/x11-apps/xkbset/files/xkbset-0.5-ldflags.patch b/x11-apps/xkbset/files/xkbset-0.5-ldflags.patch
index 69dda8739d75..440d428b7a68 100644
--- a/x11-apps/xkbset/files/xkbset-0.5-ldflags.patch
+++ b/x11-apps/xkbset/files/xkbset-0.5-ldflags.patch
@@ -1,5 +1,5 @@
---- xkbset-0.5/Makefile
-+++ xkbset-0.5/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -11,7 +11,7 @@
all: xkbset xkbset.1
diff --git a/x11-apps/xkbset/xkbset-0.5_p5_p1.ebuild b/x11-apps/xkbset/xkbset-0.5_p5_p1.ebuild
new file mode 100644
index 000000000000..f21621ae5176
--- /dev/null
+++ b/x11-apps/xkbset/xkbset-0.5_p5_p1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils toolchain-funcs versionator
+
+DEBIAN_P_MAJOR=$(get_version_component_range 3)
+DEBIAN_P_MAJOR=${DEBIAN_P_MAJOR/p/}
+DEBIAN_P_MINOR=$(get_version_component_range 4)
+DEBIAN_P_MINOR=${DEBIAN_P_MINOR/p/}
+
+DESCRIPTION="User preference utility for XKB extensions for X"
+HOMEPAGE="http://www.math.missouri.edu/~stephen/software/"
+SRC_URI="
+ http://www.math.missouri.edu/~stephen/software/${PN}/${P/_p*/}.tar.gz
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV/_p*/}-${DEBIAN_P_MAJOR}.${DEBIAN_P_MINOR}.diff.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk"
+
+CDEPEND="
+ x11-libs/libX11
+"
+DEPEND="
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ tk? ( dev-perl/Tk )
+"
+
+S=${WORKDIR}/${P/_p*/}
+
+PATCHES=(
+ "${FILESDIR}"/${P/_p*/}-ldflags.patch
+ "${WORKDIR}"/${PN}_${PV/_p*}-${DEBIAN_P_MAJOR}.${DEBIAN_P_MINOR}.diff
+ "${WORKDIR}"/${P/_p*/}/debian/patches/02_clarify_errors.dpatch
+)
+
+src_compile() {
+ emake CC=$(tc-getCC) INC_PATH= LIB_PATH=
+}
+
+src_install() {
+ dobin xkbset
+ use tk && dobin xkbset-gui
+ doman xkbset.1
+ dodoc README TODO
+}