summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-08-01 10:38:20 +0200
committerHans de Graaff <graaff@gentoo.org>2020-08-01 11:03:27 +0200
commitd164305e4ba9124dfd26c5fd4cff89eb742a598d (patch)
treef61710554757b5cdd334fb2f17e393d41c599217
parentdev-ruby/openssl-ccm: add ruby27 (diff)
downloadgentoo-d164305e.tar.gz
gentoo-d164305e.tar.bz2
gentoo-d164305e.zip
dev-ruby/omniauth: cleanup
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/omniauth/Manifest1
-rw-r--r--dev-ruby/omniauth/omniauth-1.9.0.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/omniauth/Manifest b/dev-ruby/omniauth/Manifest
index 5ff4d5727a13..ef5990b98239 100644
--- a/dev-ruby/omniauth/Manifest
+++ b/dev-ruby/omniauth/Manifest
@@ -1,2 +1 @@
-DIST omniauth-1.9.0.tar.gz 26060 BLAKE2B d0b7cd7536fc19184f56cc2b383ff70d7556d4794fb2981738216b770c340cc14025f1241a40260c0620a7bae73906c4baad1a9ce68402f0e7882128b620005d SHA512 8505fb5081f9f4daa143925b56804d81f656523c2e65c066668f2bc5c1da50cd17a06c86856e9f6560a71ee440804a536d3e814eb5dd34a0fd0c4ababe2fdadf
DIST omniauth-1.9.1.tar.gz 26528 BLAKE2B da096ce924972c867ade4cde7e6ec90f5a7de41947f5d04ad092174baf3073ba6b235ff998551d9bbc7f6dfa2a4290eef1e1d962590591cf29f89395a554f3a9 SHA512 687ab9ad47d57d1cbe01fb7ed37754fecb3b75b7e62853070b5880ad6347a2834524a8d4042271ecd7f708ab35b7b5bd3203058ef03c3317f26f88a7639c2672
diff --git a/dev-ruby/omniauth/omniauth-1.9.0.ebuild b/dev-ruby/omniauth/omniauth-1.9.0.ebuild
deleted file mode 100644
index 83b0ae242f0d..000000000000
--- a/dev-ruby/omniauth/omniauth-1.9.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
-HOMEPAGE="https://github.com/intridea/omniauth"
-SRC_URI="https://github.com/intridea/omniauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/rack-1.6.2:* <dev-ruby/rack-3:*
- >=dev-ruby/hashie-3.4.6:3 <dev-ruby/hashie-3.7.0:3"
-ruby_add_bdepend "doc? ( dev-ruby/yard )
- test? ( dev-ruby/rack-test )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' \
- Rakefile ${PN}.gemspec || die "sed failed"
- sed -i -e '/RUBY_VERSION/,/^end/ s:^:#:' spec/helper.rb || die "sed failed"
- # maruku fails, resorting to default markdown implementation
- sed -i -e '/maruku/d' .yardopts || die "sed failed"
-
- sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc ; then
- yard || die "yard failed"
- fi
-}