summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-22 09:28:20 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-22 09:28:45 +0200
commitd16430de89f819d83890ca1cbb78e573f36dbf12 (patch)
tree49c327f94499d44ee6268fa66dc7cebd73f0c324
parentapp-misc/trash-cli: Stabilize 0.22.4.16 x86, #859598 (diff)
downloadgentoo-d16430de89f819d83890ca1cbb78e573f36dbf12.tar.gz
gentoo-d16430de89f819d83890ca1cbb78e573f36dbf12.tar.bz2
gentoo-d16430de89f819d83890ca1cbb78e573f36dbf12.zip
dev-ruby/appraisal: new package, add 2.4.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/appraisal/Manifest1
-rw-r--r--dev-ruby/appraisal/appraisal-2.4.1.ebuild38
-rw-r--r--dev-ruby/appraisal/metadata.xml12
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/appraisal/Manifest b/dev-ruby/appraisal/Manifest
new file mode 100644
index 000000000000..8bf551c9db24
--- /dev/null
+++ b/dev-ruby/appraisal/Manifest
@@ -0,0 +1 @@
+DIST appraisal-2.4.1.gem 26112 BLAKE2B 47a9e91117889c52022446cd052cc0c08891d0932ab88a74f61914dd46c1e1bbe7d2a82a6afacd749b4eaf88516d80676582d9fb593d606b8da2e7888455a739 SHA512 8f2a55e2a8e497c11f6b5f2f25c565b91ed8b8bc67b68263cbfa364a3ffeb501440a7122a09885de70b8e465e38e293aa491aa7c838d58855fed0efc63f2c219
diff --git a/dev-ruby/appraisal/appraisal-2.4.1.ebuild b/dev-ruby/appraisal/appraisal-2.4.1.ebuild
new file mode 100644
index 000000000000..32a7e1a3f600
--- /dev/null
+++ b/dev-ruby/appraisal/appraisal-2.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for testing your library against different versions of dependencies"
+HOMEPAGE="https://github.com/thoughtbot/appraisal"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/bundler
+ dev-ruby/rake
+ >=dev-ruby/thor-0.14.0
+"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/activesupport-3.2.21
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/thor/ s:^:#:' Gemfile || die
+
+ # Skip the acceptance tests since they expect to install gems from
+ # the network and do not expect multiple ruby versions to be
+ # present.
+ rm -rf spec/acceptance || die
+ sed -i -e '/built_in/ s:^:#:' spec/appraisal/appraisal_file_spec.rb || die
+}
diff --git a/dev-ruby/appraisal/metadata.xml b/dev-ruby/appraisal/metadata.xml
new file mode 100644
index 000000000000..b4b7de864849
--- /dev/null
+++ b/dev-ruby/appraisal/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">thoughtbot/appraisal</remote-id>
+ <remote-id type="rubygems">appraisal</remote-id>
+ </upstream>
+</pkgmetadata>