summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-03-06 15:18:21 -0800
committerZac Medico <zmedico@gentoo.org>2024-03-06 15:21:20 -0800
commitd16a0ef2967fc22628b8da2e49441724c6e28642 (patch)
treec4c42f426485be7183262328eef46d39fa06ae9e
parentkde-plasma/oxygen: Add missing dependency (diff)
downloadgentoo-d16a0ef2967fc22628b8da2e49441724c6e28642.tar.gz
gentoo-d16a0ef2967fc22628b8da2e49441724c6e28642.tar.bz2
gentoo-d16a0ef2967fc22628b8da2e49441724c6e28642.zip
dev-python/python-netlink: enable PEP517 build
Closes: https://bugs.gentoo.org/909958 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--dev-python/python-netlink/python-netlink-0.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/python-netlink/python-netlink-0.1.ebuild b/dev-python/python-netlink/python-netlink-0.1.ebuild
index 6f79613e74d4..986639b51678 100644
--- a/dev-python/python-netlink/python-netlink-0.1.ebuild
+++ b/dev-python/python-netlink/python-netlink-0.1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN="NetLink"
@@ -16,6 +17,7 @@ LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+BDEPEND="${DISTUTILS_DEPS}"
RDEPEND="!dev-libs/libnl[python(-)]"
python_prepare_all() {