summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-09-30 18:12:07 -0700
committerZac Medico <zmedico@gentoo.org>2022-09-30 18:12:27 -0700
commitd18a0711af5dafc6cf5a24644526723ef945ba1b (patch)
tree7e97f8512f65e05d7fbe034eb0fc6d89535ef4f7
parentapp-misc/livecd-tools: use HTTPS for EGIT_REPO_URI (diff)
downloadgentoo-d18a0711.tar.gz
gentoo-d18a0711.tar.bz2
gentoo-d18a0711.zip
app-admin/consul-template: add 0.29.4
Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-admin/consul-template/Manifest2
-rw-r--r--app-admin/consul-template/consul-template-0.29.4.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/consul-template/Manifest b/app-admin/consul-template/Manifest
index 9dc24c045c01..b5f4e0463115 100644
--- a/app-admin/consul-template/Manifest
+++ b/app-admin/consul-template/Manifest
@@ -2,3 +2,5 @@ DIST consul-template-0.29.0-deps.tar.xz 37430348 BLAKE2B 9e0af3e245420bb3166a56b
DIST consul-template-0.29.0.tar.gz 244446 BLAKE2B 9ff2b33d9a3ca296913bf4f5e6928b789341438a566b63e841e04b0ad528d13588bcdb34994a1d3a829c7d64593b9811480fcf9395d3527a09d473d90bdf4e23 SHA512 e562d89c753ca2bbd14ae57e084e7e2b0aac28c92c210357e22d32d5c3c138054a46f5fb8883a44f64bdd8e9654f457230cef3b24513fa7eeaefd177fd8004c7
DIST consul-template-0.29.1-deps.tar.xz 59041120 BLAKE2B dd822c41cf9fdfe773ed48edbc02eb409b4840c9bd6f6b66c590d2fa6a44ccea3bcac89569abf318abd2c97e7515e600ee2f1f6c469c60d068959f90e3487831 SHA512 37fd93e9ce064251941626c6ac6b6770e7c019d82cd5f6c113d2adb09460a02fb1644af26714b34f9634e6312346edb98cd841aee6b6805f7d06a07fc7c997d7
DIST consul-template-0.29.1.tar.gz 254592 BLAKE2B 4ad5e7c1bf2edc06d72ec1ed48f9546c698d22f8562c4c9924106891c44511b912abecc94517ed2359592b709f1f8fd05fcb00cea52893de29c62b34b61fd71e SHA512 edcfe45a3d98b9affda8b5d07fb375a647a78473c7041a87f1f5a2aa2faef2bfdef26a7037d228f6a86d0c446397e7452e7005ce16beff2bc68edabf2268a6f9
+DIST consul-template-0.29.4-deps.tar.xz 59446648 BLAKE2B 9ccd689f38eff50ad448a4226de918920c7acca9eb1e23d4e30f9999afc124224bb8f123b3dff4a1d433ea683ed523cd604a41472f50cb1919483040fc18c848 SHA512 3c60d88fdb82744f250cf02be3b3423f74360f18a43f4c4204ee97f73c370b878ecdbd5a300f96b74ffd9c7cde66f6c8b974392f7acc07a113b85ab6f1b6d8e9
+DIST consul-template-0.29.4.tar.gz 262539 BLAKE2B 487902c2a05561db325e6d2638a70d2733a27dd31f678b65883d0b4925b4efa38fe4fbe6c7128c9473af4d4a21f467288a2c1945da399f6feab39216b67dd5aa SHA512 3bc5fcd1877fe125398d6bf0bd4938af88cacf726441af3e82142e651ab458185593eec3cb7c5916669a0e39dff8059c049556509ec279bf572f03b4c915d757
diff --git a/app-admin/consul-template/consul-template-0.29.4.ebuild b/app-admin/consul-template/consul-template-0.29.4.ebuild
new file mode 100644
index 000000000000..612bb41f3539
--- /dev/null
+++ b/app-admin/consul-template/consul-template-0.29.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module systemd
+
+DESCRIPTION="Generic template rendering and notifications with Consul"
+HOMEPAGE="https://github.com/hashicorp/consul-template"
+SRC_URI="https://github.com/hashicorp/consul-template/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 ISC MIT WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="
+ acct-group/consul-template
+ acct-user/consul-template"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+# TODO: debug test failures
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ # remove -s and -w from the linker flags
+ sed \
+ -e '/-s \\/d' \
+ -e '/-w \\/d' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake GOBIN="${S}"/bin dev
+}
+
+src_test() {
+ emake GOBIN="${S}"/bin test
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc CHANGELOG.md README.md
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ keepdir /etc/${PN}.d
+
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}