summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-27 07:12:03 +0100
committerSam James <sam@gentoo.org>2022-08-27 07:12:16 +0100
commitd194026c3f297ce21c94de8f8b2293dbedc47087 (patch)
tree41d6037ef9493d8e00d3d06e79602f65bb9950c9
parentdev-libs/boehm-gc: add 8.2.2 (diff)
downloadgentoo-d194026c3f297ce21c94de8f8b2293dbedc47087.tar.gz
gentoo-d194026c3f297ce21c94de8f8b2293dbedc47087.tar.bz2
gentoo-d194026c3f297ce21c94de8f8b2293dbedc47087.zip
app-office/texstudio: add 4.3.1, drop 9999
Live ebuild was out of sync anyway & no template. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-office/texstudio/Manifest1
-rw-r--r--app-office/texstudio/texstudio-4.3.1.ebuild (renamed from app-office/texstudio/texstudio-9999.ebuild)17
2 files changed, 11 insertions, 7 deletions
diff --git a/app-office/texstudio/Manifest b/app-office/texstudio/Manifest
index affff84f7160..a0e41255833d 100644
--- a/app-office/texstudio/Manifest
+++ b/app-office/texstudio/Manifest
@@ -1,2 +1,3 @@
DIST texstudio-4.1.2.tar.gz 88666134 BLAKE2B 7c4310fd0d8fd446b8844f11c687f55818f7314a2e0614ac26b8023f8fa7e5eca1b60a3b3c0ce61ccb15d383b61c24280a67dd530a907b4b8e00a965b10230bf SHA512 0b88f82514462c363e6dcee899f3681883ce9db1bb21cbf9e5e657208338bba4a6cdb79feeaefb242350bc01b83851c5d2704a7d0e2888034070ef2588b77964
DIST texstudio-4.2.2.tar.gz 89234106 BLAKE2B a54b632ca6cf87410164f0a365f9a60b16cc51ea6ef12250b6ae6230ca7657615b3c91a88d995b2c654cbd42cda72b0e83af0b9471f87358f3f9a24270118d82 SHA512 b07dbe03b9b825fd2c6c057d996dad1247151d0034503d6e62426f0c4ff1e982da8eddf801e497bf9743349d41401ac9946f828c276f164aec0955c8324f5dea
+DIST texstudio-4.3.1.tar.gz 90529450 BLAKE2B 500f42f8a540aff97d8bb8d65262d6e0a758ccfb431fa00d9aa6e848d76da9eb1320dc3bc5a472e15d4492174e2817181271243c581830958c5e370751ed0b36 SHA512 6fc8717ed22e21947260d0af5c5b857f9b79476f28f400f9036134d9de2d9e11a605a871b6c8d520b366cb43f3fb61bb89c411e5c11aee1e87642e77fe1b0560
diff --git a/app-office/texstudio/texstudio-9999.ebuild b/app-office/texstudio/texstudio-4.3.1.ebuild
index 8c4937f86d75..25a2b9ebb237 100644
--- a/app-office/texstudio/texstudio-9999.ebuild
+++ b/app-office/texstudio/texstudio-4.3.1.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit desktop git-r3 qmake-utils xdg
+inherit desktop qmake-utils xdg
MY_PV="${PV/_/}"
DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
-EGIT_REPO_URI="https://github.com/texstudio-org/texstudio.git"
+SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${MY_PV}"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="video"
DEPEND="
@@ -50,8 +51,6 @@ PATCHES=(
)
src_prepare() {
- xdg_src_prepare
-
# TODO: find hunspell quazip utilities/poppler-data qtsingleapplication -delete || die
rm -r src/quazip || die
@@ -61,10 +60,11 @@ src_prepare() {
sed -e "/qtsingleapplication.pri/s/.*/CONFIG += qtsingleapplication/" \
-i ${PN}.pro || die
+ default
}
src_configure() {
- eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1
+ eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1 NO_TESTS=false
}
src_install() {
@@ -74,4 +74,7 @@ src_install() {
done
emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+
+ # We don't install licences per package
+ rm "${ED}"/usr/share/texstudio/COPYING || die
}