summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-30 05:16:14 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-30 06:26:52 +0200
commitd1a4f925d72868835ad4cabc2153bcd2928d0e88 (patch)
tree387da86f21c176d66142937d3e84a29f71bdb181
parentdev-python/botocore: Bump to 1.27.20 (diff)
downloadgentoo-d1a4f925d72868835ad4cabc2153bcd2928d0e88.tar.gz
gentoo-d1a4f925d72868835ad4cabc2153bcd2928d0e88.tar.bz2
gentoo-d1a4f925d72868835ad4cabc2153bcd2928d0e88.zip
dev-python/boto3: Bump to 1.24.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.20.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 7ca8c5b6ff7a..0c8640032651 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -6,4 +6,5 @@ DIST boto3-1.24.16.gh.tar.gz 511182 BLAKE2B 00180c2cee9499efb3093c517f776536a859
DIST boto3-1.24.17.gh.tar.gz 511281 BLAKE2B 577efc0ebfb39957e55bcaf7aa678cdf072eed885ab1055b15fc8ca2295fedd6d56fd2fb919913beedcdd335ff26e452bc5434283c9ca9d8f0135080e2aa1312 SHA512 a843146951eb2a5ad7dd31159d833806ae403014abf3e9a617f6457e3ecec1a0dc4c6ce6a87079c9112513cbd6a2ccd26542e5736eeea6c5723c7e39c660befa
DIST boto3-1.24.18.gh.tar.gz 511407 BLAKE2B a723c58db4cf11a982aa5b779cd27870c96fc63d08dc733f5c7c70bcd027c4ec542c5f988bdab6dd35d9c72bd985b21473b6bc58604ef4ae84b7993de42e754c SHA512 369200635e7c52761ea13f4755e8c105dca92259922e947d777b1400f69f8ed443ae6dae0df4f8c46cdf5493819be696ab4b200216d86285ac68ccc817ecd13e
DIST boto3-1.24.19.gh.tar.gz 511808 BLAKE2B b59ddc7826f30833ca5b4ea5b71a2c1f19662cb108e93e4455908788d8357addf7edfdbe993b855fcd1ee063f4def7176376b08757d69745ff2ccaeea908f46d SHA512 007ca70cf4510c6069d80fb885e6b4d4eb8724b333765b60c2cc283f01d1771e9238f61469e303e853045544c6ae2409fa171a3e72e29659f1893fbb9731c98e
+DIST boto3-1.24.20.gh.tar.gz 512415 BLAKE2B c2196a9a518b0e4c0fb6e2382390d7d8e275d834a363856c266f696d57b5d56bf7f6a07df10d44670189098b19e0fcfad2a4907af10cd0d6361a5b2164bd6269 SHA512 cb4e426654895e26867a165304d03a722465441e10bf4dfd76fd7c5b45289785ba83f4f66c45d256a5ef6beb3cf5dfa923ea7479e99361344288ad98350a68a6
DIST boto3-1.24.7.gh.tar.gz 508670 BLAKE2B d526f6a4dc4c6126c61ca7c9074b4341c742f84a6e95b38cd8a450fb74df379cee44513e1be6bc7cd0c8f728598d0ecfc06240120a8da71f75f86371498f5233 SHA512 4d57e38c18138b950f93a234132ac1d31c9a29ad00ca5e1298517d6b16ff2849802ce6cfeb8de390c2eb25086043d45e0276a7a563707595649ca1905367be52
diff --git a/dev-python/boto3/boto3-1.24.20.ebuild b/dev-python/boto3/boto3-1.24.20.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.20.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}