summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2022-05-02 16:09:40 +0800
committerBenda Xu <heroxbd@gentoo.org>2022-05-03 13:41:34 +0800
commitd1a5e4f1cebf3de99434df6945d2586ba04e7b8c (patch)
tree9c2f8c3d37b79010df980264f94164b5808d77fe
parentsci-libs/rocThrust: bump to 5.0.2 (diff)
downloadgentoo-d1a5e4f1cebf3de99434df6945d2586ba04e7b8c.tar.gz
gentoo-d1a5e4f1cebf3de99434df6945d2586ba04e7b8c.tar.bz2
gentoo-d1a5e4f1cebf3de99434df6945d2586ba04e7b8c.zip
sci-libs/rocRAND: bump to version 5.0.2
Tests all passed on single Radeon RX 6700XT (gfx1031) Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--sci-libs/rocRAND/Manifest1
-rw-r--r--sci-libs/rocRAND/rocRAND-5.0.2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sci-libs/rocRAND/Manifest b/sci-libs/rocRAND/Manifest
index b6eb6f2bfe43..1463032b13ee 100644
--- a/sci-libs/rocRAND/Manifest
+++ b/sci-libs/rocRAND/Manifest
@@ -1,2 +1,3 @@
DIST rocRAND-4.0.0.tar.gz 3105585 BLAKE2B 0466d88c286290a9cd179fac61209051f7db5323457ccad9c5f0b579439662e1fe2b8951f85101c7c31bd058bc1448e839a19dc9a3a2d4ca42eb4e0b2baf4eb4 SHA512 c02bc32a9cf7660739ecf7ef99262fb14efa2c76afb3476105eedc4264dec987351ebd461c13c9e0aef9e640b42960b2a63295479664b83924cf0d5c34a157e8
DIST rocRAND-4.3.0.tar.gz 3107367 BLAKE2B 23cfac271c1cd4e4edcfd315aa775d4d62e6a50ffa3b9a3372d4ae427a02def52486e88b3f4f89daaa539f2653cf76c8d44afec70d8d916268bc9f27534bda4c SHA512 3eefeb55014a8ee681e1cee73e0e092bd29a81767e772e712f8f871e94380a772a433e93a59276b0cd5a364fc4e482186771809d67ebdab24b2e3020173f5e18
+DIST rocRAND-5.0.2.tar.gz 11765778 BLAKE2B f93c3530fba2b416c5ef3d227ebe65f3ee36607e6b4e1d0584c410768b9d71f86c40468bfad0935afb8ca13c7c87b20ee23f1ea89bdedcb6b3149fd932cbdbe6 SHA512 c19beb0eef8dcf4e090e53cb544f21adb61f8c9cb463c74da1c9767b1d75539bb3e296e7b8a70dee517817d181abd8c713e22770a1a4f66363150a879cbb3e48
diff --git a/sci-libs/rocRAND/rocRAND-5.0.2.ebuild b/sci-libs/rocRAND/rocRAND-5.0.2.ebuild
new file mode 100644
index 000000000000..aa2a6bdbd3ec
--- /dev/null
+++ b/sci-libs/rocRAND/rocRAND-5.0.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Generate pseudo-random and quasi-random numbers"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocRAND"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/rocRAND/archive/rocm-${PV}.tar.gz -> rocRAND-${PV}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="benchmark test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/hip"
+DEPEND="${RDEPEND}
+dev-util/rocm-cmake
+test? ( dev-cpp/gtest )"
+BDEPEND="dev-util/rocm-cmake
+>=dev-util/cmake-3.22"
+
+S="${WORKDIR}/rocRAND-rocm-${PV}"
+
+src_prepare() {
+ sed -r -e "s:(hip|roc)rand/lib:\${CMAKE_INSTALL_LIBDIR}:" \
+ -e "s:(hip|roc)rand/include:include/\1rand:" \
+ -e "/INSTALL_RPATH/d" -i library/CMakeLists.txt || die
+
+ # remove GIT dependency
+ sed -e "/find_package(Git/,+4d" -i cmake/Dependencies.cmake || die
+
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Grant access to the device
+ addwrite /dev/kfd
+ addpredict /dev/dri/
+
+ # Compiler to use
+ export CXX=hipcc
+
+ local mycmakeargs=(
+ -DBUILD_TEST=$(usex test ON OFF)
+ -DBUILD_BENCHMARK=$(usex benchmark ON OFF)
+ -DCMAKE_SKIP_RPATH=TRUE
+ ${AMDGPU_TARGETS+-DAMDGPU_TARGETS="${AMDGPU_TARGETS}"}
+ )
+
+ cmake_src_configure
+ # do not rerun cmake and the build process in src_install
+ sed '/RERUN/,+1d' -i "${BUILD_DIR}"/build.ninja || die
+}
+
+src_test() {
+ # Grant access to the device
+ addwrite /dev/kfd
+ addwrite /dev/dri/
+ LD_LIBRARY_PATH="${BUILD_DIR}/library" cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ if use benchmark; then
+ cd "${BUILD_DIR}"/benchmark
+ dobin benchmark_rocrand_*
+ fi
+}