summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-03-17 12:16:20 -0700
committerMatt Turner <mattst88@gentoo.org>2019-03-17 12:17:01 -0700
commitd1abced69636438a165a5cb3ea0844af8219c73c (patch)
tree59188a557fb6f6e026f03940701658cfa8ecc470
parentx11-libs/pixman: Convert build to meson (diff)
downloadgentoo-d1abced69636438a165a5cb3ea0844af8219c73c.tar.gz
gentoo-d1abced69636438a165a5cb3ea0844af8219c73c.tar.bz2
gentoo-d1abced69636438a165a5cb3ea0844af8219c73c.zip
x11-libs/pixman: Version bump to 0.38.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/pixman/Manifest1
-rw-r--r--x11-libs/pixman/pixman-0.38.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/pixman/Manifest b/x11-libs/pixman/Manifest
index 257e9213fc3e..776df0c874c0 100644
--- a/x11-libs/pixman/Manifest
+++ b/x11-libs/pixman/Manifest
@@ -1 +1,2 @@
DIST pixman-0.36.0.tar.bz2 739957 BLAKE2B 05834dbed8a5bfed607a20f78523e7441f5b78a7a01c7d302c48b8f15dcda37111a8a99e7119b84a0a8a26b55fa93db1c2af316359095cb7db0d8a9e263a1eb7 SHA512 ed99c85a8ce11f52659da61bff599c0405ae0069c30434bdef7238bc9f18e83e6d534cddf38c14d753943edbaeba580c5005ad7575f27e469ca7be7878678d21
+DIST pixman-0.38.0.tar.gz 891291 BLAKE2B 8d057fba6d85ab4d2bb83903e8f1a6ac05659be4d0645782f5cf4c190e7b27fa0e7d6b2718ab111bd8ded9b617c7aad42dbfdf2169d49816b7eaf6e6673c6a5f SHA512 1b0205dbe9d9185c68813ce577a889f3c83e83fbd9955c3a72d411c3b476e6be93fc246b5b6ef4ee17e2bb8eb6fb5559e01dff7feb6a6c4c6314f980e960d690
diff --git a/x11-libs/pixman/pixman-0.38.0.ebuild b/x11-libs/pixman/pixman-0.38.0.ebuild
new file mode 100644
index 000000000000..d7ab4c45e9b1
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.38.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/pixman/pixman.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson multilib-minimal
+
+DESCRIPTION="Low-level pixel manipulation routines"
+HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+ SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="altivec cpu_flags_arm_iwmmxt loongson2f cpu_flags_x86_mmxext neon cpu_flags_x86_sse2 cpu_flags_x86_ssse3"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature cpu_flags_arm_iwmmxt iwmmxt)
+ $(meson_feature cpu_flags_x86_mmxext mmx)
+ $(meson_feature cpu_flags_x86_sse2 sse2)
+ $(meson_feature cpu_flags_x86_ssse3 ssse3)
+ $(meson_feature altivec vmx)
+ $(meson_feature neon neon)
+ $(meson_feature loongson2f loongson-mmi)
+ -Dgtk=disabled
+ -Dlibpng=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}