summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2019-01-11 07:02:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-04 02:12:04 +0100
commitd1d2d72d68520427a73ef5075c1530eb8c8ea4d6 (patch)
tree1366e2cecc54c23d0fdc44d32134d5e51648e911
parentdev-libs/efl: drop old (diff)
downloadgentoo-d1d2d72d.tar.gz
gentoo-d1d2d72d.tar.bz2
gentoo-d1d2d72d.zip
x11-terms/terminology: revbump 1.3.2 to correct dependency
Package-Manager: Portage[mgorny]-2.3.51.1 Signed-off-by: Joonas Niilola <juippis@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--x11-terms/terminology/terminology-1.3.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-terms/terminology/terminology-1.3.2-r1.ebuild b/x11-terms/terminology/terminology-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..3f81250defd3
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.3.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://fau.re/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="nls"
+
+RDEPEND="
+ || ( dev-libs/efl[gles2] dev-libs/efl[opengl] )
+ || ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ dev-libs/efl[eet,fontconfig]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ )
+
+ meson_src_configure
+}