summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-03-02 21:50:53 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-03-02 21:50:53 +0100
commitd23aa06fb9ce58308d7ce59f2ceb6ea4bcf5a09c (patch)
tree2c697d47885159eb016b9c3cab3fc9ecd2db7643
parentx11-misc/dunst: update live ebuild (diff)
downloadgentoo-d23aa06f.tar.gz
gentoo-d23aa06f.tar.bz2
gentoo-d23aa06f.zip
media-gfx/exact-image: compatible with openexr:3
Closes: https://bugs.gentoo.org/834328 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--media-gfx/exact-image/exact-image-1.0.2-r3.ebuild (renamed from media-gfx/exact-image/exact-image-1.0.2-r2.ebuild)15
1 files changed, 9 insertions, 6 deletions
diff --git a/media-gfx/exact-image/exact-image-1.0.2-r2.ebuild b/media-gfx/exact-image/exact-image-1.0.2-r3.ebuild
index 32d67a26443a..700070540cde 100644
--- a/media-gfx/exact-image/exact-image-1.0.2-r2.ebuild
+++ b/media-gfx/exact-image/exact-image-1.0.2-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,7 +15,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="expat jpeg lua openexr php perl png ruby swig tiff truetype X"
-REQUIRED_USE="lua? ( swig )"
+REQUIRED_USE="lua? ( swig ) perl? ( swig ) php? ( swig ) ruby? ( swig )"
RDEPEND="
x11-libs/agg[truetype]
@@ -23,7 +23,7 @@ RDEPEND="
expat? ( dev-libs/expat )
jpeg? ( virtual/jpeg )
lua? ( ${LUA_DEPS} )
- openexr? ( <media-libs/openexr-3.0.0:0= )
+ openexr? ( media-libs/openexr:= )
php? ( dev-lang/php:* )
perl? ( dev-lang/perl )
png? ( >=media-libs/libpng-1.2.43 )
@@ -35,8 +35,7 @@ RDEPEND="
x11-libs/libXt
x11-libs/libICE
x11-libs/libSM
- )
-"
+ )"
DEPEND="
${RDEPEND}
swig? ( dev-lang/swig )
@@ -72,6 +71,11 @@ src_prepare() {
sed -i \
-e 's/strcpy(\([^,]*\)\(,["a-zA-Z -]*\))/memcpy(\1\2, sizeof(\1))/' \
codecs/tga.cc || die
+
+ # openexr vers 3
+ sed -i \
+ -e 's:Int64:uint64_t:g' \
+ codecs/openexr.cc || die
}
src_configure() {
@@ -97,7 +101,6 @@ src_configure() {
--without-bardecode \
$(use_with lua) \
$(use_with swig) \
- --without-python \
$(use_with perl) \
--without-python \
$(use_with php) \