summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-06 06:46:14 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-06 06:46:14 +0200
commitd2451a2fc66b265523b409ae5edd98d052e969f3 (patch)
tree7a4f756dec2b13377cced5a6d85c971c17af48b1
parentdev-python/jaraco-functools: Bump to 3.8.1 (diff)
downloadgentoo-d2451a2fc66b265523b409ae5edd98d052e969f3.tar.gz
gentoo-d2451a2fc66b265523b409ae5edd98d052e969f3.tar.bz2
gentoo-d2451a2fc66b265523b409ae5edd98d052e969f3.zip
dev-python/hypothesis: Bump to 6.82.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.82.1.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index f28c3fb9bf3b..c1a3751a2ae4 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-6.80.1.gh.tar.gz 9376526 BLAKE2B edb7012b17f1634745d81de74934424
DIST hypothesis-6.81.1.gh.tar.gz 9377813 BLAKE2B 6ba0d9bd8fd12d521909151c7bb04ea729df1adb4dc401359de7accf75cf78981c3e2dbda1c22cb05ca48d550f8a97d19deea86249ac056b5fc34fca20ffb2b7 SHA512 54d13f249fe02fdd99726304a87ca1fe174f47137006fe147ed2b47875136f2d77f24be0bb77e91a04edff8db2230563627c75e9d164adf859284e5ce873369d
DIST hypothesis-6.81.2.gh.tar.gz 9378154 BLAKE2B d4654e8de621af93fa6ab013bf45ea1c2e8b273f38cf0dddbe00853d197487acf2a9457a33e59fd59b9c5c7dca08a84867a835cdfa8e4a63181df5105889c360 SHA512 41f5e6b8382c08dd0e4285836a3f1308f6666d86387e10899c5ef8839598e097d31a5360cf7d47f2d30c287ad575787ecb44c236ad83c52202cf8895046c56a0
DIST hypothesis-6.82.0.gh.tar.gz 9378337 BLAKE2B fb99a499c7b850c4d81f01b99969d611ee8a39a1b1d1a5306b72999b1ca20d605fb42adbc090eedbe06359056d05860e2166be9f8f8001460ea61b398a432de6 SHA512 2f8b16c1a32340a3aa742627cbbc958cb06e8966b704bd389c8677d58fc3e76e6988705315d570daeb46975839b1c725f5f6a937ff1c326cbed144659ec44d05
+DIST hypothesis-6.82.1.gh.tar.gz 9378717 BLAKE2B 2127d101f5c477fa99abe07df09928d0be475dd052f8f121ec038488eb4b5b35508b09524ae06ae8fe41712724fbb50f8db4aa72472a7315cc3ad68b9000371e SHA512 3fb983b2246aaa9860694f07eee9fafb28f560b3ba105544d3d4345ba323543f194109b710c639e86287572ad5ed141c2edf6c89c0f4a71a003505a797effddc
diff --git a/dev-python/hypothesis/hypothesis-6.82.1.ebuild b/dev-python/hypothesis/hypothesis-6.82.1.ebuild
new file mode 100644
index 000000000000..ed1f0cbc8e14
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.82.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}