summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-12-31 00:24:26 +0100
committerLouis Sautier <sbraz@gentoo.org>2021-12-31 00:28:05 +0100
commitd255f1d578a98e5aae92bbb14df3412850e6eb2b (patch)
treeb768b0fb61d598ba85b3c1962a5da9820ae07dba
parentapp-misc/mime-types: destabilize 9 (diff)
downloadgentoo-d255f1d5.tar.gz
gentoo-d255f1d5.tar.bz2
gentoo-d255f1d5.zip
app-admin/supervisor: add 4.2.4
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--app-admin/supervisor/Manifest1
-rw-r--r--app-admin/supervisor/supervisor-4.2.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index a69d766839e7..c461f2f8bbd0 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -1,3 +1,4 @@
DIST supervisor-4.2.0.tar.gz 456056 BLAKE2B 51b66cfc34505b937c47c9b510d81bcc777b9372fdeb2e08fc25153d2718cd2682258b812630160954587ceb992e1a528cdd5bf0d270139f7ffac9463ac2f015 SHA512 626d806f4b03be7cbff795afd1bdb3ff5ca5ecf44f035909ea1aa9360da9fa3047b2fe05543190bf1442f01dcdd403be19fcd907519bf7e26615900bc4bf9d0f
DIST supervisor-4.2.1.tar.gz 460935 BLAKE2B 0c65f904599c1e8a04cd3a71085e2b2a5460691c2bfd790d3b7c10449cae08472bcd72a870cbe611801434624f405ea3e245f156cab93f25a8df784b58d948d7 SHA512 c560ef959f8d580fb20c1812aa2a838c9feaeb3726a754e8084fa8c7406ff9258139b55b081558b8d8f33e4672cdfad40695170f55412a5e85a6c1aed0f11657
DIST supervisor-4.2.2.tar.gz 463657 BLAKE2B 766feffcbd70b575b6b7dfd6ed98e3510e0fd9362c423b677d44a2b5dd23ded14a349a279d3d28d4fd9e04a2175c8f00e24c07df310b61d34c7f69f60d26a4ac SHA512 f787206e6c6a5d3dfc4284974a4a87cbcaeac0c705afb2b8eae53f066413bd9e68095c5309e29625e01469a4748613370e1ac0d7be84b9d72c3623244bdd2eb3
+DIST supervisor-4.2.4.tar.gz 465151 BLAKE2B 91b99a64950dc874bdc008ba53ca8b1962cc34981fee27c2fd82956d73ace9eaaf91439ef6be40530c4860fe1eee193e19b51ab81050f7368aa7d31f8444c785 SHA512 38c55aeadb8664337b667aad891a3a2134ae4af88e90d636054e6be9aebc8a3ef87d79d15fcafd2b9966af562deeedc96ac3730bde9439dde30208f0a874f2d7
diff --git a/app-admin/supervisor/supervisor-4.2.4.ebuild b/app-admin/supervisor/supervisor-4.2.4.ebuild
new file mode 100644
index 000000000000..27a705ecefd4
--- /dev/null
+++ b/app-admin/supervisor/supervisor-4.2.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="acct-group/supervisor"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newinitd "${FILESDIR}/init.d-r2" supervisord
+ newconfd "${FILESDIR}/conf.d-r1" supervisord
+ dodoc supervisor/skel/sample.conf
+ keepdir /etc/supervisord.d
+ insinto /etc
+ doins "${FILESDIR}/supervisord.conf"
+ keepdir /var/log/supervisor
+ systemd_dounit "${FILESDIR}/supervisord.service"
+}
+
+pkg_preinst() {
+ fowners :supervisor /var/log/supervisor
+ fperms 750 /var/log/supervisor
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You may install your configuration files in ${EROOT}/etc/supervisord.d"
+ elog "For config examples, see ${EROOT}/usr/share/doc/${PF}/sample.conf.bz2"
+ elog ""
+ elog "By default, only members of the supervisor group can run supervisorctl."
+ fi
+}