summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2023-09-08 14:52:40 +0000
committerUlrich Müller <ulm@gentoo.org>2023-11-24 09:15:28 +0100
commitd25c17bdf136e7086648fdc4178ee6a82f021a55 (patch)
tree1a1cb6ea454c777bb43118f9f5b4b2e0b889fa7d
parentmedia-video/yle-dl: add 20231120 (diff)
downloadgentoo-d25c17bdf136e7086648fdc4178ee6a82f021a55.tar.gz
gentoo-d25c17bdf136e7086648fdc4178ee6a82f021a55.tar.bz2
gentoo-d25c17bdf136e7086648fdc4178ee6a82f021a55.zip
dev-libs/ferrisloki: update EAPI 6 -> 8
Fix the configure phase when /bin/sh -> dash. Closes: https://bugs.gentoo.org/886619 Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--dev-libs/ferrisloki/ferrisloki-3.0.13-r3.ebuild40
-rw-r--r--dev-libs/ferrisloki/files/ferrisloki-3.0.13-r3-configure-libsigc.patch97
2 files changed, 137 insertions, 0 deletions
diff --git a/dev-libs/ferrisloki/ferrisloki-3.0.13-r3.ebuild b/dev-libs/ferrisloki/ferrisloki-3.0.13-r3.ebuild
new file mode 100644
index 000000000000..8dc40fd0ca57
--- /dev/null
+++ b/dev-libs/ferrisloki/ferrisloki-3.0.13-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="Loki C++ library from Modern C++ Design"
+HOMEPAGE="https://data-room-software.org/libferris/"
+SRC_URI="mirror://sourceforge/witme/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-libs/libsigc++-2.6:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.13-r3-configure-libsigc.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ econf
+}
+
+src_install() {
+ default
+
+ # package provides .pc files
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/ferrisloki/files/ferrisloki-3.0.13-r3-configure-libsigc.patch b/dev-libs/ferrisloki/files/ferrisloki-3.0.13-r3-configure-libsigc.patch
new file mode 100644
index 000000000000..7c543a91d405
--- /dev/null
+++ b/dev-libs/ferrisloki/files/ferrisloki-3.0.13-r3-configure-libsigc.patch
@@ -0,0 +1,97 @@
+Rollup of src_prepare() from previous revisions plus additional fixes
+
+ * derice damn configure script
+ * fix building with libsgc++-2.6
+ * fix building with /bin/sh -> dash (bug #886619)
+--- a/configure.in
++++ b/configure.in
+@@ -1,4 +1,5 @@
+ AC_INIT(ferrisloki, 3.0.13)
++AC_CONFIG_MACRO_DIR([macros])
+
+ PACKAGE=$PACKAGE_NAME
+ VERSION=$PACKAGE_VERSION
+@@ -45,9 +46,6 @@ AC_STDC_HEADERS
+ #AC_ARG_PROGRAM
+ AM_PROG_LIBTOOL
+
+-STLPORT_CFLAGS=""
+-STLPORT_LDFLAGS=""
+-
+ ###############################################################################
+ ###############################################################################
+ ###############################################################################
+@@ -57,12 +55,6 @@ AM_FERRIS_SIGC2( 2.0.0 )
+
+ ###############################################################################
+
+-CFLAGS=" $STLPORT_CFLAGS $CXXFLAGS -DNDEBUG "
+-CXXFLAGS=" $STLPORT_CFLAGS $CXXFLAGS -DNDEBUG "
+-LDFLAGS=" $STLPORT_LDFLAGS $LDFLAGS"
+-AC_SUBST(CFLAGS)
+-AC_SUBST(CPPFLAGS)
+-AC_SUBST(LDFLAGS)
+ AC_SUBST(CXXFLAGS)
+ AC_SUBST(CXXCPPFLAGS)
+
+--- a/macros/ferrismacros.m4
++++ b/macros/ferrismacros.m4
+@@ -303,30 +303,6 @@ if test x"$have_stlport" = xno; then
+
+ AC_LANG_CPLUSPLUS
+ STLPORT_IO64_CFLAGS=" -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 "
+-
+- AC_CHECK_PROG( have_stlportcfg, stlport-config, yes, no )
+-
+- if test "$have_stlportcfg" = yes; then
+-
+-# AC_PATH_GENERIC( STLPORT, 4.5, [ have_stlport=yes ], [foo=2] )
+- stlport_installed_version=`stlport-config --version`
+-
+- # Calculate the available version number
+- [f_tmp=( `echo $stlport_installed_version | sed 's/[^0-9]\+/ /g'` )]
+- [f_tmp=$(( 1000000 * ${f_tmp[0]:-0} + 1000 * ${f_tmp[1]:-0} + ${f_tmp[2]:-0} ))]
+-
+- [freq_version=( `echo $stlport_required_version | sed 's/[^0-9]\+/ /g'` )]
+- [freq_version=$(( 1000000 * ${freq_version[0]:-0} + 1000 * ${freq_version[1]:-0} + ${freq_version[2]:-0} ))]
+-
+- if test $freq_version -gt $f_tmp ; then
+- AC_MSG_WARN([STLPort version $1 is required, you have $stlport_installed_version])
+- else
+- have_stlport=yes
+- STLPORT_LIBS=" `stlport-config --libs` -lpthread "
+- STLPORT_CFLAGS=" `stlport-config --cflags` "
+- AM_FERRIS_STLPORT_INTERNAL_TRYLINK( [have_stlport=yes], [have_stlport=no] )
+- fi
+- fi
+ fi
+
+ if test x"$have_stlport" = xno; then
+@@ -442,15 +418,11 @@ dnl
+ stlport_required_version=$1
+ have_stlport=no
+
+-attempt_to_use_stlport=yes
++attempt_to_use_stlport=no
+ AC_ARG_ENABLE(stlport,
+ [--disable-stlport Don't use STLport even if it is detected],
+ [
+- if test x$enableval = xyes; then
+- attempt_to_use_stlport=yes
+- else
+- attempt_to_use_stlport=no
+- fi
++ attempt_to_use_stlport=no
+ ])
+
+ echo "attempt_to_use_stlport:${attempt_to_use_stlport}"
+--- a/src/Extensions.hh
++++ b/src/Extensions.hh
+@@ -29,7 +29,6 @@
+ ******************************************************************************/
+
+ #include <sigc++/signal.h>
+-#include <sigc++/object.h>
+ #include <loki/SmartPtr.h>
+ #include <loki/SmallObj.h>
+