summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-29 04:37:02 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-29 04:37:02 +0100
commitd27ba32455819b87b85c13f56ea9684c738535b1 (patch)
treed92ba16524d592381f7d6109687524d09ea4d7dd
parentdev-cpp/simpleini: add 4.22, drop 4.21 (diff)
downloadgentoo-d27ba324.tar.gz
gentoo-d27ba324.tar.bz2
gentoo-d27ba324.zip
dev-python/botocore: Bump to 1.34.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.10.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 3bbc08dba7f8..1484d82ed408 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,4 +1,5 @@
DIST botocore-1.33.11.gh.tar.gz 12536159 BLAKE2B bce09ad1b93210667e3c1058ab3b4350b752e330c78c29af87c53b3f3f738dd7622b1b670a4fdbfa2dfdeaf763f9885b3f82ad0eb4f44c7e7585ae5b8eaa6b5d SHA512 5d790bbb909230861cf2eb38908f5876ab9bd7e5dd1f718987797af0b263c7ea2c42d69aa1d55b66d1b954204caa04c50cd050385607637192e9ad6b33f65b7d
+DIST botocore-1.34.10.gh.tar.gz 12610559 BLAKE2B c58bc5745d598e3822de5bbaf6ade619a75d90e4bb03bfd9d2fee0b372011d4e5b475e773c06624aa73c3ee18c0490da55c9f17b7804fa33b00b2d0764a7b995 SHA512 aca9bf3f2e3fba4c073063193cb996df0b38e13b8658cd43b02a2a5e0ba4200e6f6e7933963eaeaf2847e5dc7323ed76eb398b3952d6865baf05e12cfbf5024b
DIST botocore-1.34.2.gh.tar.gz 12564834 BLAKE2B b22a3d3bd35b769a28ccb1a5116428e1904d0c9fc3452829237704dbec37a31a539f044a728b0785d09406d299d522dd601da39801249747d54e6741b46cafe2 SHA512 a3f3718bf584a871abbb3edc803de9d5329da257c050d56bdbf8a6a6c4067477812582fbd8d1d789ce18ea1f416d0ddb2be9cc3c45172292d061a94a12f3977b
DIST botocore-1.34.7.gh.tar.gz 12606475 BLAKE2B 387ee7dfab43c44c39c7b0566b6ddcb2b666024b5b7bee2c996194988781c169e1e9462b36d09861d1c3ca899d263392f3d79129e7a2f2fc4bbfed402f5c7dd6 SHA512 3f162d4d028dd81da552e0117671971aa891bf8fab513730f40083660fa83c1f82bf1b52875cf9f7f11089ecdd79f084f3c8e76227aa826c1aac7e5735032450
DIST botocore-1.34.8.gh.tar.gz 12607766 BLAKE2B df29d3846dcb5096708223b5b4c59a2f9a7dcf213c5691bf0a619fb4c9c6ceab5fbecefce6f8ddd76752b420fcfb95bfc7ae00c933172a7f1d9281b7b08f3049 SHA512 4359320cc619cde5bf938cec00b430f6daa8bfeb0170bb476dd3a6be0ba3464aeccd6a422e4d1487a1d7ed6721cb2ffdc55465d289fcccb82f3a5ff142b782b4
diff --git a/dev-python/botocore/botocore-1.34.10.ebuild b/dev-python/botocore/botocore-1.34.10.ebuild
new file mode 100644
index 000000000000..05766e84276c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.10.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}