summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2020-05-05 16:54:11 -0400
committerMike Frysinger <vapier@gentoo.org>2020-05-05 16:54:38 -0400
commitd2a33cbab3ae69ed9537ab43542a927dd470f1e9 (patch)
tree5a689ac668f8af87205033d5c8a56ed526fe0d03
parentdev-python/requests-cache: add py3.7 & py3.8 & EAPI=7 (diff)
downloadgentoo-d2a33cba.tar.gz
gentoo-d2a33cba.tar.bz2
gentoo-d2a33cba.zip
dev-python/tvdb_api: add py3.7 & py3.8 & EAPI=7
Fixes: https://bugs.gentoo.org/719596 Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-rw-r--r--dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild b/dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild
new file mode 100644
index 000000000000..4b2690e43f55
--- /dev/null
+++ b/dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to thetvdb.com API"
+HOMEPAGE="https://github.com/dbr/tvdb_api"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/requests-cache[${PYTHON_USEDEP}]"