summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-12 00:57:09 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-20 10:01:41 -0400
commitd2aaa2c3e2104ae745612bb945a35e69657c56a1 (patch)
treea042259c0c814533d18cfaf72830940db37b9319
parentmedia-libs/kvazaar: Keyword 2.2.0 riscv, #902217 (diff)
downloadgentoo-d2aaa2c3.tar.gz
gentoo-d2aaa2c3.tar.bz2
gentoo-d2aaa2c3.zip
mail-client/evolution: Version bump to 3.48.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--mail-client/evolution/Manifest1
-rw-r--r--mail-client/evolution/evolution-3.48.0.ebuild151
-rw-r--r--profiles/package.mask1
3 files changed, 153 insertions, 0 deletions
diff --git a/mail-client/evolution/Manifest b/mail-client/evolution/Manifest
index 53ebe97f969e..8cb672c7221d 100644
--- a/mail-client/evolution/Manifest
+++ b/mail-client/evolution/Manifest
@@ -1,2 +1,3 @@
DIST evolution-3.46.3.tar.xz 13372368 BLAKE2B 55e7f551d91e867f2307caf82f43640ee593c9b18f83c8f2ec2c3493075bb87a4421bc2df722156b3a12e6ac84536e1db92de2dfca72315a09cd99828811f0e8 SHA512 3c832509dba78a07dd7521c049214377108a1866c754afb1c756f9a487b648612480b4a17d853d9ec59f1c209667b29b5711f1e5e1b336e344cbed7bf8dd4069
DIST evolution-3.46.4.tar.xz 13374292 BLAKE2B 2d75548d1e2a3b9b539419613830a04ac904c37a85d995ed793c95642ca8336a504d0f5191f495b305af5ed47a1f1a2133062bc7e5f6c75d851961f8b8bd4509 SHA512 349270f84ee435452601e49a942478d9ef8060638b74135478b0f531bebc7be99019be749d7acb14237e9ff042e0443db30f053465ebc9f821263d86d8d8ae95
+DIST evolution-3.48.0.tar.xz 13427316 BLAKE2B bbf6722b8772f83f116748e247bb941b750a3f1b92c7a19cbe47848185f618a3413b67625bee0582ea89054571f0b637fff5c97b4cc545d4d87c3ff60d320fc6 SHA512 a57b2df1eb0aac7f10244b1c8b520a2ac6442699763c992820653bc758a9fd775ab290b0a2c39cb51805b4db9dfbbf0510f29085844406eae66c676c7c5671f4
diff --git a/mail-client/evolution/evolution-3.48.0.ebuild b/mail-client/evolution/evolution-3.48.0.ebuild
new file mode 100644
index 000000000000..915b9f86c631
--- /dev/null
+++ b/mail-client/evolution/evolution-3.48.0.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2 readme.gentoo-r1
+
+DESCRIPTION="Integrated mail, addressbook and calendaring functionality"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution https://gitlab.gnome.org/GNOME/evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) CC-BY-SA-3.0 FDL-1.3+ OPENLDAP"
+SLOT="2.0"
+
+IUSE="archive +bogofilter geolocation gtk-doc highlight ldap spamassassin spell ssl +weather ytnef"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# glade-3 support is for maintainers only per configure.ac
+# pst is not mature enough and changes API/ABI frequently
+# dconf explicitly needed for backup plugin
+# gnome-desktop support is optional with --enable-gnome-desktop
+# automagic libunity dep
+# >=gspell-1.8 to ensure it uses enchant:2 like webkit-gtk
+DEPEND="
+ >=app-text/enchant-2.2.0:2
+ >=dev-db/sqlite-3.7.17:3
+ >=dev-libs/glib-2.66:2[dbus]
+ >=dev-libs/libxml2-2.7.3:2
+ >=gnome-base/gnome-desktop-2.91.3:3=
+ >=gnome-base/gsettings-desktop-schemas-2.91.92
+ >=gnome-extra/evolution-data-server-${PV}:=[gtk,weather?]
+ >=media-libs/libcanberra-0.25[gtk3]
+ >=net-libs/libsoup-3.0:3.0
+ >=net-libs/webkit-gtk-2.38.0:4.1=[spell?]
+ >=x11-libs/cairo-1.9.15[glib]
+ >=x11-libs/gdk-pixbuf-2.24:2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libnotify-0.7
+ >=x11-misc/shared-mime-info-0.22
+
+ app-text/cmark:=
+ >=app-text/iso-codes-0.49
+ >=app-accessibility/at-spi2-core-2.46.0:2
+
+ gnome-base/dconf
+ x11-libs/libSM
+ x11-libs/libICE
+
+ archive? ( >=app-arch/gnome-autoar-0.1.1[gtk] )
+ bogofilter? ( mail-filter/bogofilter )
+ geolocation? (
+ >=media-libs/libchamplain-0.12.21:0.12[gtk]
+ >=media-libs/clutter-1.0.0:1.0
+ >=media-libs/clutter-gtk-0.90:1.0
+ >=sci-geosciences/geocode-glib-3.26.3:2 )
+ ldap? ( >=net-nds/openldap-2:= )
+ spamassassin? ( mail-filter/spamassassin )
+ spell? ( >=app-text/gspell-1.8:= )
+ ssl? (
+ >=dev-libs/nspr-4.6.1
+ >=dev-libs/nss-3.11
+ )
+ weather? (
+ >=dev-libs/libgweather-4.2.0:4=
+ >=sci-geosciences/geocode-glib-3.26.3:2
+ )
+ ytnef? ( net-mail/ytnef )
+"
+RDEPEND="${DEPEND}
+ highlight? ( app-text/highlight )
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="To change the default browser if you are not using GNOME, edit
+~/.local/share/applications/mimeapps.list so it includes the
+following content:
+
+[Default Applications]
+x-scheme-handler/http=firefox.desktop
+x-scheme-handler/https=firefox.desktop
+
+(replace firefox.desktop with the name of the appropriate .desktop
+file from /usr/share/applications if you use a different browser)."
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DENABLE_SCHEMAS_COMPILE=OFF
+ -DENABLE_GTK_DOC=$(usex gtk-doc)
+ -DWITH_OPENLDAP=$(usex ldap)
+ -DENABLE_SMIME=$(usex ssl)
+ -DENABLE_GNOME_DESKTOP=ON
+ -DWITH_ENCHANT_VERSION=2
+ -DENABLE_CANBERRA=ON
+ -DENABLE_AUTOAR=$(usex archive)
+ -DWITH_HELP=ON
+ -DENABLE_YTNEF=OFF
+ -DWITH_BOGOFILTER=$(usex bogofilter)
+ -DWITH_SPAMASSASSIN=$(usex spamassassin)
+ -DENABLE_GSPELL=$(usex spell)
+ -DENABLE_TEXT_HIGHLIGHT=$(usex highlight)
+ -DENABLE_WEATHER=$(usex weather)
+ -DENABLE_CONTACT_MAPS=$(usex geolocation)
+ -DENABLE_YTNEF=$(usex ytnef)
+ -DENABLE_PST_IMPORT=OFF
+ -DWITH_GLADE_CATALOG=OFF
+ -DENABLE_MARKDOWN=ON
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index f4bf4218cef5..49675d309c3d 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -178,6 +178,7 @@ dev-ruby/net-http-persistent:3
>=gnome-extra/gnome-weather-44_rc
>=gui-apps/gnome-console-44_beta
>=gui-libs/libadwaita-1.3_rc
+>=mail-client/evolution-3.48
>=media-gfx/eog-44_beta
>=media-gfx/gnome-font-viewer-44_rc
>=net-libs/glib-networking-2.76_beta