summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-09-03 00:48:07 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-09-03 01:33:16 +0200
commitd2ad299798b58873b9f72ab57c4e15e9a226131c (patch)
tree34e9102ba9d8b291010854ccfd31a6d48497251f
parentdev-libs/libgdata: fix build dependency issue on gnome-online-accounts, bug #... (diff)
downloadgentoo-d2ad299798b.tar.gz
gentoo-d2ad299798b.tar.bz2
gentoo-d2ad299798b.zip
dev-libs/libgdata: drop old revisions
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-libs/libgdata/libgdata-0.17.8.ebuild64
-rw-r--r--dev-libs/libgdata/libgdata-0.17.9.ebuild66
2 files changed, 0 insertions, 130 deletions
diff --git a/dev-libs/libgdata/libgdata-0.17.8.ebuild b/dev-libs/libgdata/libgdata-0.17.8.ebuild
deleted file mode 100644
index 7c6ac6bb7a98..000000000000
--- a/dev-libs/libgdata/libgdata-0.17.8.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-VALA_USE_DEPEND="vapigen"
-
-inherit gnome2 vala
-
-DESCRIPTION="GLib-based library for accessing online service APIs using the GData protocol"
-HOMEPAGE="https://wiki.gnome.org/Projects/libgdata"
-
-LICENSE="LGPL-2.1+"
-SLOT="0/22" # subslot = libgdata soname version
-
-IUSE="+crypt gnome-online-accounts +introspection static-libs test vala"
-REQUIRED_USE="
- gnome-online-accounts? ( crypt )
- vala? ( introspection )
-"
-
-KEYWORDS="alpha amd64 ~arm ~arm64 hppa ~ia64 ~ppc ~ppc64 sparc x86"
-
-RDEPEND="
- >=dev-libs/glib-2.38.0:2
- >=dev-libs/json-glib-0.15
- >=dev-libs/libxml2-2:2
- >=net-libs/liboauth-0.9.4
- >=net-libs/libsoup-2.55.90:2.4[introspection?]
- >=x11-libs/gdk-pixbuf-2.14:2
- crypt? ( app-crypt/gcr:= )
- gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8:= )
- introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.25
- >=dev-util/intltool-0.40
- virtual/pkgconfig
- test? ( >=net-libs/uhttpmock-0.5 )
- vala? ( $(vala_depend) )
-"
-
-src_prepare() {
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- # configure checks for gtk:3, but only uses it for demos which are not installed
- gnome2_src_configure \
- $(use_enable crypt gnome) \
- $(use_enable gnome-online-accounts goa) \
- $(use_enable introspection) \
- $(use_enable vala) \
- $(use_enable static-libs static) \
- $(use_enable test always-build-tests) \
- GTK_CFLAGS= \
- GTK_LIBS=
-}
-
-src_test() {
- unset ORBIT_SOCKETDIR
- export GSETTINGS_BACKEND="memory" #486412
- dbus-launch emake check
-}
diff --git a/dev-libs/libgdata/libgdata-0.17.9.ebuild b/dev-libs/libgdata/libgdata-0.17.9.ebuild
deleted file mode 100644
index 03f112101253..000000000000
--- a/dev-libs/libgdata/libgdata-0.17.9.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-VALA_USE_DEPEND="vapigen"
-GNOME2_EAUTORECONF="yes"
-
-inherit gnome2 vala
-
-DESCRIPTION="GLib-based library for accessing online service APIs using the GData protocol"
-HOMEPAGE="https://wiki.gnome.org/Projects/libgdata"
-
-LICENSE="LGPL-2.1+"
-SLOT="0/22" # subslot = libgdata soname version
-
-IUSE="+crypt gnome-online-accounts +introspection static-libs test vala"
-REQUIRED_USE="
- gnome-online-accounts? ( crypt )
- vala? ( introspection )
-"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="
- >=dev-libs/glib-2.44.0:2
- >=dev-libs/json-glib-0.15
- >=dev-libs/libxml2-2:2
- >=net-libs/liboauth-0.9.4
- >=net-libs/libsoup-2.55.90:2.4[introspection?]
- >=x11-libs/gdk-pixbuf-2.14:2
- crypt? ( app-crypt/gcr:= )
- gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8:= )
- introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.25
- >=dev-util/intltool-0.40
- virtual/pkgconfig
- test? ( >=net-libs/uhttpmock-0.5 )
- vala? ( $(vala_depend) )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.17.8-disable-demos.patch
-)
-
-src_prepare() {
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-build-demos \
- $(use_enable crypt gnome) \
- $(use_enable gnome-online-accounts goa) \
- $(use_enable introspection) \
- $(use_enable vala) \
- $(use_enable static-libs static) \
- $(use_enable test always-build-tests)
-}
-
-src_test() {
- unset ORBIT_SOCKETDIR
- dbus-run-session emake check
-}