summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-25 23:26:08 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-25 23:26:08 -0500
commitd2c6c988cb34001f6d0ce5931c54aed7be494ea4 (patch)
treec15ea8768b4f277fda8ef265d526f05f534109b4
parentx11-terms/kitty-terminfo: add 0.32.1 (diff)
downloadgentoo-d2c6c988cb34001f6d0ce5931c54aed7be494ea4.tar.gz
gentoo-d2c6c988cb34001f6d0ce5931c54aed7be494ea4.tar.bz2
gentoo-d2c6c988cb34001f6d0ce5931c54aed7be494ea4.zip
x11-terms/kitty: add 0.32.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty/Manifest3
-rw-r--r--x11-terms/kitty/kitty-0.32.1.ebuild176
2 files changed, 179 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 764aace987f3..6c7906344708 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -4,3 +4,6 @@ DIST kitty-0.31.0.tar.xz.sig 566 BLAKE2B 5013b35dd7119b5bed3e4fefee70009f6fe6ba8
DIST kitty-0.32.0-vendor.tar.xz 1404384 BLAKE2B 5b7d2af146429354e25d9b4f5c43a769535ad9a3b31b5a2944b8d8e7f045630734bd8e92c3f40c5dd7111d5014b9b356972896c0ba005392fbb740bc4bb30b20 SHA512 00b94033ea8b6ae3bbe509fdc2443aa7405a59ff9c04d86b96bd4dfe002367517b5b1fa99f27b8e2424917bb6b2eaa5959e8f470cd524de6388760870779af89
DIST kitty-0.32.0.tar.xz 8122660 BLAKE2B 8f2fccb8f233612331b860e0b25aa5a028c2e4d39b5795132351c4a2dff51478b8e42fd3a15bec5f616b4cdb47ad0cc7f636d1961a7f9fad8ede91475e82c29e SHA512 d64f36c20d484724b0215a2ffc9044b83ddaa476926377e6c79226d7d6bd5deffda9964291a99c0df174640fb2fa7df0464435d2cef19304eab7b1d135cc1847
DIST kitty-0.32.0.tar.xz.sig 566 BLAKE2B e925423321ec88fd0e7cc4f356c92b9ca9d992dce4c480c383368eff81f97bae4ac5a1d2cc2a7a2f3603f32448aa5d817c2319681dd1e2c24150834e137f55fa SHA512 fe7ce2dceb22ee477d6a9e3b308f4ef54287d1656f949511e80a6c9ee1d921bab5599675e354e6dd8b35719b0ff5373a9cca73b255da3c03aaed239e7355c897
+DIST kitty-0.32.1-vendor.tar.xz 1404632 BLAKE2B 660bd55dbcc5816af36aa8d918170805d0b06fb17b0f7fc4048fb55cdf9bf131e8d28f3d14cf912ddebc598b6749d66b9bd89fc087dfd0564c28e170fb0b2156 SHA512 6bd272fe73fd3a0307c7a0d3cec0ff5831133977ed02948ace1f0a1cc69b59409aa450d75fd107a56f8e64ee1b59750b6350dc70afd029f412c8d7c4f53e991d
+DIST kitty-0.32.1.tar.xz 8115412 BLAKE2B 493b250c3b456e895646175602997d902f457f8935be2b2cc21e41f6efbc963865eff6157d31427a65e9d0976e87965a646ef77cfdee28d96aeb710e6a905c4c SHA512 4be50093b2da7a6536548f8bf36ea86ab47238a1f346e10d4384a90d2d0d0e02f8d98dc6a463ffa7c7a93268202b5a4109f28e2b7ece1d9593f590691e5e1af8
+DIST kitty-0.32.1.tar.xz.sig 566 BLAKE2B 6eee10a20448a1ed35a8f2b29b143af7787eafe55f05786cecbe9d775c88f1da4e5ca969ee434a76817eb6f22eb57d8a8ffa95ed8c7d9a102cadb0cc9952f782 SHA512 3dd6e10f2db91c989b15c9007e6bab8db4aea77530f43c753fa91e98cc9084110f46ad1a71eb5105618ff3145b2f9ca2da0ace6c4edb2c1ea15aa7ad82ab328f
diff --git a/x11-terms/kitty/kitty-0.32.1.ebuild b/x11-terms/kitty/kitty-0.32.1.ebuild
new file mode 100644
index 000000000000..ad738d565f30
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.32.1.ebuild
@@ -0,0 +1,176 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit edo go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD BSD-2 MIT MPL-2.0" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )
+"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ media-libs/fontconfig
+ media-libs/harfbuzz:=[truetype]
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcursor
+ )
+ wayland? ( dev-libs/wayland )
+ !sci-mathematics/kissat
+"
+DEPEND="
+ ${RDEPEND}
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )
+"
+# bug #919751 wrt go subslot
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.21:=
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )
+"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc no-sudo"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ rm -r linux-package/share/terminfo || die # provided by kitty-terminfo
+
+ if [[ ${PV} == 9999 ]]; then
+ mkdir -p linux-package/share/doc/${PF} || die
+ else
+ mv linux-package/share/doc/{${PN},${PF}} || die
+ fi
+
+ # generate default config as reference, command taken from docs/conf.rst
+ if ! tc-is-cross-compiler; then
+ linux-package/bin/kitty +runpy \
+ 'from kitty.config import *; print(commented_out_default_config())' \
+ > linux-package/share/doc/${PF}/kitty.conf || die
+ fi
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ edo mv linux-package "${ED}"/usr
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}