summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-21 23:49:39 +0000
committerSam James <sam@gentoo.org>2022-01-21 23:49:39 +0000
commitd2ccfa6c9af38d82d01fe63a73faa4f14a7ba18e (patch)
tree5083faeb12037104083beefa99a566e9782cc5f2
parentsys-libs/readline: add 8.2_alpha (diff)
downloadgentoo-d2ccfa6c.tar.gz
gentoo-d2ccfa6c.tar.bz2
gentoo-d2ccfa6c.zip
app-shells/bash: use system readline 8.2_alpha for 5.2_alpha
Added a note to tidy up the logic in future too. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/bash/bash-5.2_alpha.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-shells/bash/bash-5.2_alpha.ebuild b/app-shells/bash/bash-5.2_alpha.ebuild
index 61a2aecd2b7c..99181307ddc7 100644
--- a/app-shells/bash/bash-5.2_alpha.ebuild
+++ b/app-shells/bash/bash-5.2_alpha.ebuild
@@ -3,6 +3,12 @@
EAPI=7
+# TODO on release:
+# - check READLINE_VER, obviously
+# - remove autotools/eautoreconf from readline ebuild
+# - tidy up is_release check in this ebuild for using system readline
+# (presumably there weren't always readline releases for bash RCs etc)
+
inherit flag-o-matic toolchain-funcs prefix
# Official patchlevel
@@ -154,7 +160,8 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=${READLINE_VER%%_*}
- if is_release ; then
+ # TODO: Clean this up before 5.2 release
+ if [[ ${PV} == 5.2_alpha ]] || is_release ; then
# Use system readline only with released versions.
myconf+=( --with-installed-readline=. )
fi