summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-26 21:44:41 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-26 22:56:26 +0100
commitd2ce663795e7cb6e68c01f0092ef83b9712d403b (patch)
tree84e8abc607d77d7ee116575705e21e9e6db468c0
parentdev-python/botocore: Bump to 1.23.14 (diff)
downloadgentoo-d2ce6637.tar.gz
gentoo-d2ce6637.tar.bz2
gentoo-d2ce6637.zip
dev-python/boto3: Bump to 1.20.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.14.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 958ea9f11f45..e7b9c329da95 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,6 +5,7 @@ DIST boto3-1.20.10.tar.gz 443886 BLAKE2B 891c5d45eed9fc0afac3e6e87f5f7d2100da779
DIST boto3-1.20.11.tar.gz 444945 BLAKE2B ead4a78e67c12dfeccfe2c55e88ff9ed0ed2d024d04a89f82f31c87fe01ddbb425ddcd0ce54955c02b4fc8468b3684a5289bd3a3da5fd5e472f8b8a88e75c26f SHA512 d68ee2b61f3aeb34b137a347c41e96da0d3f04fb700369886e5081290f29fb479f84992c92d5dc79cee67b8c74146590669f99ff21a6bfd2e04c8aff33b3d5d7
DIST boto3-1.20.12.tar.gz 447029 BLAKE2B 191a8fb12e8e61ea354acc42db3513dfbc95e60e901f696a6b92a9891deb4bd7e835daa18057d36e926ccb375856244204c5ed46238f311eb27499d50d5d7f2e SHA512 19cedff433d5256b305d743dd50bd754ce6b6227c5f820a51741ae76736d70a6adf04192f60533f1cafadb670503d05912847d82e355088be9b21d1e37e4d1dc
DIST boto3-1.20.13.tar.gz 448520 BLAKE2B 0354d9a66fdee4a82f23c1e8bd1b7f78f53e941cf2c603f1740efa9e6a86b92f52b4eb57e6892ea1f5a3b5e05872a2a2d8f4321b29b4b11adf2885c5eb8ea731 SHA512 ef4857d14c40e70e656d51d1126f49da48fa6a79a58cae9bb6cdb2490d3ef3153165a23ad8c6f99cc553ea140b3030b4e8855c2a832a54086e54ca6e6acef790
+DIST boto3-1.20.14.tar.gz 449126 BLAKE2B b2ef8a101aaecb5d65a60fcbf7f83e89946181092bb4ad1f4a7abcf8b218c5ce797a47cd9ac3e7fdee85c6457d89b91836729f4019f5ecebf1193d015714ca8a SHA512 ff4e3f2accde84fe71cdcb090775c384700d3cba0d43f46a834b653f6a9493d7cd57be1741f39378cddf315d5f5ce07f4f233c300feb1529c22e99a0817af85c
DIST boto3-1.20.5.tar.gz 439166 BLAKE2B c140e15e497e6cdf6b4b77bb99e0a0f5ac01d5b5793f8bfb210b52bbc09e39e6fe06a957951375e0795210dc1c3b2a0afd2f498bc88e449d9e6846f2b357f016 SHA512 2823466e4851684253d4ce42a8c34e5cbdad6d04c823040fe2cebdf0cffb14d5d3f40e28d57ebec14533fab04ba74f27c25f078ddb8791b8f52d0424e11b39fc
DIST boto3-1.20.6.tar.gz 440133 BLAKE2B b154714261372cebb8643d529b66fe3a42d30e056cf2a454092d598c51d0cdef723980834be6a36abb892d3022ae8ef67053b22bb176f540e67c3f37422155d8 SHA512 d8d66a761f03beeca10fea8446de1136d418a93b21065aebfefcafe2abfd9b5bbfa243594f54647ad80547e48348086e2be2de129b89f9ca71f308579f11a0b7
DIST boto3-1.20.7.tar.gz 440428 BLAKE2B f1b2b36799e6c22a40c04226443f15f9174d68a02d2f731df84f6ff0962158e9d940ae5bc04d25fe99a74f105946026ccb66547838734294d649d661071c1e3b SHA512 85493a85789caa5453a4dafa1472c8ecd75c05a819227909092ae03690243eb103c1588cb10e5e5277ab9df49673b9b54fda064a412bdcf6b9e11238b277f450
diff --git a/dev-python/boto3/boto3-1.20.14.ebuild b/dev-python/boto3/boto3-1.20.14.ebuild
new file mode 100644
index 000000000000..a4f6b1d0f3c2
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.14.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}