summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-11 04:24:41 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-11 04:24:41 +0100
commitd2d926394db6a25d7e4ad7083edf41d349963db7 (patch)
tree69006bd2d0358559e63eb75686e7a15283fff879
parentdev-python/tqdm: Bump to 4.66.2 (diff)
downloadgentoo-d2d926394db6a25d7e4ad7083edf41d349963db7.tar.gz
gentoo-d2d926394db6a25d7e4ad7083edf41d349963db7.tar.bz2
gentoo-d2d926394db6a25d7e4ad7083edf41d349963db7.zip
dev-python/pytest-describe: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-describe/Manifest1
-rw-r--r--dev-python/pytest-describe/pytest-describe-2.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-describe/Manifest b/dev-python/pytest-describe/Manifest
index 344436ec5567..72e39f4c6dad 100644
--- a/dev-python/pytest-describe/Manifest
+++ b/dev-python/pytest-describe/Manifest
@@ -1 +1,2 @@
DIST pytest-describe-2.1.0.tar.gz 10272 BLAKE2B aa0ff1cdcdeeea7f5dee444502eb304415c91d4a54d7caa1b0daa3f6e9546947a51d6d801ca6befaf5f8633f0d4c770c9b7218e2ea1f0412d11a8b21abd3c284 SHA512 ca15a6d2c3bc42cf9bc7dd4359c4e6d1e793862ab256e1b43940f8d1605cb065d260128c6931a79226b5288caa67f0c3934650ce95aa413d65200c53fdc1f817
+DIST pytest-describe-2.2.0.tar.gz 10907 BLAKE2B 1a99cf3060b36caa44fba91d71ae2e66d13dd68c397c1469af1b93f5fee93ace9ef52d985fdd04c46805ab7d50be3f5af1344cec8b8c1d88f4c752d2afa6f58f SHA512 d4bb79edeeb7169deeabbc7f98700b8084f14ba7596c523a52634637cdb642a76a203b15b6c40b23c08de578dafe43a232f39bbc55caee23aeca61558e51cdc9
diff --git a/dev-python/pytest-describe/pytest-describe-2.2.0.ebuild b/dev-python/pytest-describe/pytest-describe-2.2.0.ebuild
new file mode 100644
index 000000000000..4335fc3fa5e3
--- /dev/null
+++ b/dev-python/pytest-describe/pytest-describe-2.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Describe-style plugin for pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-describe/
+ https://pypi.org/project/pytest-describe/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/pytest-9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_describe.plugin
+ epytest
+}