summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-19 08:06:39 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-19 08:57:17 +0200
commitd2f4266418f0adc314a750fbcbda75108b94d4db (patch)
tree7fcc0b825f213e45096ece8b60f919be9f270382
parentdev-python/pyjwt: Bump to 2.8.0 (diff)
downloadgentoo-d2f4266418f0adc314a750fbcbda75108b94d4db.tar.gz
gentoo-d2f4266418f0adc314a750fbcbda75108b94d4db.tar.bz2
gentoo-d2f4266418f0adc314a750fbcbda75108b94d4db.zip
dev-python/jsonschema-specifications: Bump to 2023.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jsonschema-specifications/Manifest1
-rw-r--r--dev-python/jsonschema-specifications/jsonschema-specifications-2023.7.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jsonschema-specifications/Manifest b/dev-python/jsonschema-specifications/Manifest
index 5d12559b27e4..01217b23edb0 100644
--- a/dev-python/jsonschema-specifications/Manifest
+++ b/dev-python/jsonschema-specifications/Manifest
@@ -1,2 +1,3 @@
DIST jsonschema_specifications-2023.5.2.tar.gz 12581 BLAKE2B 74029c066e3c620126ed0ed7e70a9b63c017aeab827b0187f8c8c5964c2e1ef68a83489f4646d79653c38fcec45bc001189fc09295ac1f569ed288f2dc469459 SHA512 222a70e3c1673c6f3d27f5d6561d4ba192c61a8a6f86e726939d1e29843eeca82de306a889540ab352a5c2332cf30d810db956aa5094f2a6bc6607b7169513fd
DIST jsonschema_specifications-2023.6.1.tar.gz 12645 BLAKE2B 9dea1acae9e53a9f8ff93dd54d5df3bb1dd960036dfcc4dcc0c6287ae816c0ca60c139b35aa14901e2e9f61dca339cf9d84a5c5e8f91a62a40696db9daa1a099 SHA512 b7a0d7fdc642e08cf3515dfae6d8cbb14e4d40c3b1fe3cb6c87ee11c47a9d6ede33b28d9fe6f3d4f0ff1807469a015cd8fcacff9575a356a74b462af9681aa6c
+DIST jsonschema_specifications-2023.7.1.tar.gz 12689 BLAKE2B 421b0e94161c84c658a9af1ddef74fb98ca18332a2977e1ca983b04995bc0a65b3399edd4a2a52c741a4ffdbeeb4a0796371448f283ba328c72c1899f3f0b55a SHA512 78275fe6595151c611baeeebc17f08287f50a3636c3de515abfe8dc45075136874740dfa169aa3ebda004b5ead66ba93bc22b963ded14e4aa906e4b454356f7c
diff --git a/dev-python/jsonschema-specifications/jsonschema-specifications-2023.7.1.ebuild b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.7.1.ebuild
new file mode 100644
index 000000000000..4a8d6fc88665
--- /dev/null
+++ b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.7.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The JSON Schema meta-schemas and vocabularies, exposed as a Registry"
+HOMEPAGE="
+ https://github.com/python-jsonschema/jsonschema-specifications/
+ https://pypi.org/project/jsonschema-specifications/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/referencing-0.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest