summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-28 03:04:55 +0100
committerSam James <sam@gentoo.org>2021-07-28 03:04:55 +0100
commitd2f8da8db6b4b87cfdf9b37c1071049af6eaed35 (patch)
tree823d2aca0d17bc474ff008a88cbce2b192c01b78
parentdev-ml/rresult: add 0.6.0 (diff)
downloadgentoo-d2f8da8db6b4b87cfdf9b37c1071049af6eaed35.tar.gz
gentoo-d2f8da8db6b4b87cfdf9b37c1071049af6eaed35.tar.bz2
gentoo-d2f8da8db6b4b87cfdf9b37c1071049af6eaed35.zip
dev-ml/fpath: add 0.7.3
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/fpath/Manifest1
-rw-r--r--dev-ml/fpath/fpath-0.7.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/fpath/Manifest b/dev-ml/fpath/Manifest
index 0f8bf4b12584..c46046bf7280 100644
--- a/dev-ml/fpath/Manifest
+++ b/dev-ml/fpath/Manifest
@@ -1 +1,2 @@
DIST fpath-0.7.2.tbz 24142 BLAKE2B 5aa22a33d0155c2a446c3622d6feef0748be3eaa72f07e7e2770fda1993794864072a5f50a052537b9724e39935064967c87f82d860a2da17fbc86279a1930ab SHA512 d8ab8d6f183a1742d74a3a3220cc1d62e7df38a6f3ca1c04fad18426a0897152255382305ad14d058b5b85ab55a27536c39a62deffac8d46984a730a2a18405d
+DIST fpath-0.7.3.tbz 24345 BLAKE2B 5d4e68acebdafb6378422b31385e78decff2dfce1bedd102c7e6baac519f9843e0828629f4a15e075f506865e1af6f9cc7ece761e74fe6608d3476338cc556cb SHA512 acf4b379aee3c25305ef71d1b97b154faa6de1e8248a8e8d046cf11090a3e94f2dc048b961bb51725ca7384e784455f2893fbd51f26bf80571a9cc7e9475b945
diff --git a/dev-ml/fpath/fpath-0.7.3.ebuild b/dev-ml/fpath/fpath-0.7.3.ebuild
new file mode 100644
index 000000000000..13e85c27b103
--- /dev/null
+++ b/dev-ml/fpath/fpath-0.7.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="File system paths for OCaml"
+HOMEPAGE="https://erratique.ch/software/fpath https://github.com/dbuenzli/fpath"
+SRC_URI="https://erratique.ch/software/fpath/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-ml/result:=
+ dev-ml/astring:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}