summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-03-10 12:40:28 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-03-10 12:40:47 +0100
commitd3293edd9d5c257f5e37316abfd7936ece0f6d4c (patch)
tree1b7c5689f681878b7894f9fd05268df172692292
parentx11-plugins/wmacpiload-ac: fix implicit function declarations in configure (diff)
downloadgentoo-d3293edd9d5c257f5e37316abfd7936ece0f6d4c.tar.gz
gentoo-d3293edd9d5c257f5e37316abfd7936ece0f6d4c.tar.bz2
gentoo-d3293edd9d5c257f5e37316abfd7936ece0f6d4c.zip
x11-plugins/wmMatrix: use real usleep()
Closes: https://bugs.gentoo.org/898924 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild b/x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild
index 5b686f451ee5..9106a1b5129e 100644
--- a/x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild
+++ b/x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,6 +27,12 @@ PATCHES=(
"${FILESDIR}"/${P}-fno-common.patch
)
+src_prepare() {
+ default
+ # Use real usleep on modern systems
+ sed -e "s/short_uusleep/usleep/" -i wmMatrix.c || die
+}
+
src_compile() {
# this version is distributed with compiled binaries!
make clean