summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-21 05:48:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-21 05:48:46 +0200
commitd3425c27125b4c651a37edc8c3e2ee8b0d9ad57d (patch)
tree1ae796cfab5201f38d400cd3f040b7299d5a192a
parentapp-admin/awscli: Bump to 1.27.117 (diff)
downloadgentoo-d3425c27.tar.gz
gentoo-d3425c27.tar.bz2
gentoo-d3425c27.zip
xfce-extra/xfce4-mount-plugin: Bump to 1.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-mount-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mount-plugin/Manifest b/xfce-extra/xfce4-mount-plugin/Manifest
index 1695605a6ec3..53a81e76354c 100644
--- a/xfce-extra/xfce4-mount-plugin/Manifest
+++ b/xfce-extra/xfce4-mount-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-mount-plugin-1.1.5.tar.bz2 432564 BLAKE2B 6dbdbf692847c7c236a60982adf6ac9619f8d45320c97debea44e0b865a9ac51c76b20dd80943f5fe23501d450039ab0fc4644b0ff5ed693ff169668a039441d SHA512 bf4e89c57a1f61120919a272c6f343a9fb4072a977848031784cbdf96e4bf248d878c6e28a812930daf9a0515efcae20b421e0b2db176f05b8f29d75d90a28ca
+DIST xfce4-mount-plugin-1.1.6.tar.bz2 452714 BLAKE2B 8c4491b6b863f44ba1fedbfef2bd691add9b6d10e56d193364a628504fca7ef5e3563815851db45ba9aff6af2640c377eb80525c0dd7130e987995523ec7e3f6 SHA512 5f0d8c2ebf6528560c42b5dc1408a40bce8dfc4528f2a2ea1955774a8e5fab0cda9c81b052927c7dbd8675a5bbd104a208c657f473dc5258e049fa0b34af16a3
diff --git a/xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.6.ebuild b/xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.6.ebuild
new file mode 100644
index 000000000000..ab77e47112b3
--- /dev/null
+++ b/xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="An mount plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-mount-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-mount-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}