summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokry <martin-kokos@users.noreply.github.com>2023-03-28 20:46:28 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-22 15:15:48 +0200
commitd3449642f5983c07a05bac5e68c897741d01cf4e (patch)
tree77a4347432f6b36434c61922d00ae8a1d32294a0
parentapp-emacs/pos-tip: bump to 0.4.7 (diff)
downloadgentoo-d3449642f5983c07a05bac5e68c897741d01cf4e.tar.gz
gentoo-d3449642f5983c07a05bac5e68c897741d01cf4e.tar.bz2
gentoo-d3449642f5983c07a05bac5e68c897741d01cf4e.zip
dev-python/poetry-plugin-export: New package, v1.4.0
Signed-off-by: Martin Mokry <martin-kokos@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/poetry-plugin-export/Manifest1
-rw-r--r--dev-python/poetry-plugin-export/metadata.xml16
-rw-r--r--dev-python/poetry-plugin-export/poetry-plugin-export-1.4.0.ebuild33
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/poetry-plugin-export/Manifest b/dev-python/poetry-plugin-export/Manifest
new file mode 100644
index 000000000000..e78fd051fcc0
--- /dev/null
+++ b/dev-python/poetry-plugin-export/Manifest
@@ -0,0 +1 @@
+DIST poetry_plugin_export-1.4.0.tar.gz 28553 BLAKE2B d2f7de4da9975cefde9ac02d9e4a36eada89fe00926eaf58d8ea402d57ef53209aa2e564b46616f0d71fa675512de6335a33a1714efe4a696f05c909a8313e45 SHA512 60fd1a63505e82f62372e7ec4e4908835f0556e86213b58ce836d3cf64bd6de8f83cbc965ad1a2b59c50ca3bf287675bda46b5a410a5f65078e091004eaf8ed9
diff --git a/dev-python/poetry-plugin-export/metadata.xml b/dev-python/poetry-plugin-export/metadata.xml
new file mode 100644
index 000000000000..20f252723c38
--- /dev/null
+++ b/dev-python/poetry-plugin-export/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>martin-kokos@protonmail.com</email>
+ <name>Martin Mokry</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">poetry-plugin-export</remote-id>
+ <remote-id type="github">python-poetry/poetry-plugin-export</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/poetry-plugin-export/poetry-plugin-export-1.4.0.ebuild b/dev-python/poetry-plugin-export/poetry-plugin-export-1.4.0.ebuild
new file mode 100644
index 000000000000..b69f11168144
--- /dev/null
+++ b/dev-python/poetry-plugin-export/poetry-plugin-export-1.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A plugin that allows the export of locked packages to various formats"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry-plugin-export
+ https://pypi.org/project/poetry-plugin-export/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.6.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/poetry[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest