summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-11 09:06:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-11 17:59:39 +0200
commitd34ae990de9c8da6aad3edd9ae1cf402db69c1ed (patch)
tree13fce29244f10638e0a2fcccc2741d29d63df210
parentkde-apps/cervisia: 23.04.1 version bump (diff)
downloadgentoo-d34ae990de9c8da6aad3edd9ae1cf402db69c1ed.tar.gz
gentoo-d34ae990de9c8da6aad3edd9ae1cf402db69c1ed.tar.bz2
gentoo-d34ae990de9c8da6aad3edd9ae1cf402db69c1ed.zip
kde-apps/dolphin-plugins-git: 23.04.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.04.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index 79e6a9970c86..e14acb536acd 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-22.12.3.tar.xz 272276 BLAKE2B 485ac53e070a710dbfb07aa26c915f4c2b32d5f6e67e91c3d07d9740be2c50ba4fae3c8662216423ce7e63042b663e8a59dfbfe1b490d31a2cc5445d9c3ac33c SHA512 0225fc50f88e7bd28eda74ae2bfa0c36878b9fe6b9fade6ef86a26e380cd78c8c2d1d1608796e8369f6ad545876d5d533ccfbf34b02b2be07ab8abc4bb734f7a
DIST dolphin-plugins-23.04.0.tar.xz 272516 BLAKE2B b424fc4c1cac1c7109b4ea05d97bc44e348d94d36ea5e7acb06dd171f4eee1c7278b19b004ea175b3e7d567f440a9c4b362726ae051dce061073f59e6cf280f7 SHA512 0ffdeeb9296763ef23d567ddf9929b3c3ac25cebd9d8d409f5afd5cd7765d49845a7806fb718ccee31e778d517c6eb9758fbdb15014a72d1e56083c8dd145d1d
+DIST dolphin-plugins-23.04.1.tar.xz 272580 BLAKE2B 8f1d898dd218eea4df749bff1825928fed160ed74defee154898ee57f1dc2da4ff8987438c2a49bc658544386c9ccba09a41bff6c6eaed8981baef1084e7b33e SHA512 576abc54f29f06aa2ab0d034161f159302ad33e794a8118b566e940fdea204ed3ca00e71c5dce8dfc23e876370d77e07221feaf67aea1c84ee3e089ab45a46cc
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.04.1.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.04.1.ebuild
new file mode 100644
index 000000000000..543ca78b655e
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.04.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.104.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}